您的位置:首页 > 其它

PAT(A)1003

2015-09-21 20:41 281 查看


1003. Emergency (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of
rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as
possible, and at the mean time, call up as many hands on the way as possible.

Input

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (<= 500) - the number of cities (and the cities are numbered from 0 to N-1), M - the number of roads, C1 and C2 - the cities that you are currently in
and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected
by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C1 to C2.

Output

For each test case, print in one line two numbers: the number of different shortest paths between C1 and C2, and the maximum amount of rescue teams you can possibly gather.

All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.
Sample Input
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output
2 4


1003.紧急情况
作为一个城市中的紧急救援队伍的领队,你有一张属于你的国家的特殊的地图,这张地图上有一些很分散的城市,这些城市被一些路连接到一起。每个城市所有的救援队的总数和任意连接两个城市之间的路的长度都被标记在地图上。当你接到来自其他城市的紧急电话,你的任务就是带着你的队伍尽快的赶到事件发生的地点,同时尽可能多的打电话寻求帮助。

输入:

每个输入文件包括一个测试用例。对于每个测试用例,第一行包括四个正整数:N(<=500)-代表城市的个数(从0-N-1),M-路的个数,C1和C2分别是你目前所在的城市和你将要救援的城市。下一行包括N个整数,i位置的整数就代表第i个城市所有的救援队的个数。下面是M行,每一行包括三个整数c1,c2和L,代表每条路所连接的两个城市和这条路的长度。保证C1和C2之间至少存在一条路径。

输出:

对于每个测试用例,在一行中输出两个数字:一个是C1和C2之间不同的最短路径的个数,另一个是你能找到的救援队伍的个数。

输出的数字用空格隔开,行尾没有多余空格。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <climits>
using namespace std;
const int MMAX = 1000000000;
const int MAX = 501;
int mind, cnt, maxt, n;
int weight[MAX], vis[MAX], map[MAX][MAX];
void dfs(int p, int end, int dist, int weit){
if(p == end){
if(dist < mind){
cnt = 1;
mind = dist;
maxt = weit;
}
else if(dist == mind){
cnt++;
if(maxt < weit){
maxt = weit;
}
}
return ;
}
if(dist > mind)
return ;
for(int i=0; i<n; i++){
if(vis[i] == 0 && map[p][i] != MMAX){
vis[i] = 1;
dfs(i, end, dist+map[p][i], weit+weight[i]);
vis[i] = 0;
}
}

}
int main()
{
int m, st, end, x, y, d;
mind = MMAX;
cnt = 0;
scanf("%d%d%d%d", &n, &m, &st, &end);
memset(vis, 0, sizeof(vis));
for(int i=0; i<n; i++){
for(int j=0; j<n; j++){
map[i][j] = MMAX;
}
}
for(int i=0; i<n; i++){
scanf("%d", &weight[i]);
}
while(m--){
scanf("%d%d%d", &x, &y, &d);
if(map[x][y] > d){
map[x][y] = d;
map[y][x] = d;
}
}
dfs(st, end, 0, weight[st]);
printf("%d %d\n", cnt, maxt);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: