您的位置:首页 > 其它

poj--1256

2015-09-21 20:36 183 查看

Anagram


Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 18629 Accepted: 7576

Description

You are to write a program that has to generate all possible words from a given set of letters.

Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba".

In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.

Input

The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase
letters are to be considered different. The length of each word is less than 13.

Output

For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order.
An upper case letter goes before the corresponding lower case letter.

Sample Input

3

aAb

abc

acba

Sample Output

Aab

Aba

aAb

abA

bAa

baA

abc

acb

bac

bca

cab

cba

aabc

aacb

abac

abca

acab

acba

baac

baca

bcaa

caab

caba

cbaa

题目来源:http://poj.org/problem?id=1256

考点:函数next_permutation();

解体思路:按照题目要求自定义一个比较函数,接着将数组排序成最小序列,然后调用next_permutation(),对新数组进行全排列就行了.

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char a[20];
int change(char b)
{   int t;
if(b<'a')//表示是大写字母
t=b+32;
else
t=b;
return t;
}
int cmp(char b,char c)
{
if(change(b)==change(c))
return b<c;
else return change(b)<change(c);
}//自定义比较函数
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
scanf("%s",a);
int l=strlen(a);
sort(a,a+l,cmp);
do
{
printf("%s\n",a);
}while(next_permutation(a,a+l,cmp));
}
return 0;
}
<span style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">
</span>
<span style="font-family: Arial, Helvetica, sans-serif; background-color: rgb(255, 255, 255);">求排列组合时,两个常用的函数,next_permutatio(),perv_permutation().</span>


next_permutation(),是求下一个序列,perv_permutation()是求上一个序列.一般以字典序为排序要求,当然还可以自定义排序.如果所给序列无上一个序列或下一个序列,则函数返回false.注意的是,在使用这两个函数时,要加头头文件#include<algoritnm>.
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: