您的位置:首页 > 其它

HDU1024 Max Sum Plus Plus

2015-09-21 09:07 323 查看
Problem Description

Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S1, S2, S3, S4 … Sx, … Sn (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ Sx ≤ 32767). We define a function sum(i, j) = Si + … + Sj (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i1, j1) + sum(i2, j2) + sum(i3, j3) + … + sum(im, jm) maximal (ix ≤ iy ≤ jx or ix ≤ jy ≤ jx is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(ix, jx)(1 ≤ x ≤ m) instead. ^_^

Input

Each test case will begin with two integers m and n, followed by n integers S1, S2, S3 … Sn.

Process to the end of file.

Output

Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3

2 6 -1 4 -2 3 -2 3

Sample Output

6

8

题目的意思是给定一个数组,求将其分成m个不相交字段和最大值的问题。

状态转移方程:dp[i][j]表示以i为结尾元素的j个字段的和

则dp[i][j] = max(dp[i-1][j] , dp[i-k][j-1]) + a[i];其中j-1<=k<=n+m+1

import java.util.Scanner;

public class P1024 {

final int INF = Integer.MAX_VALUE;
final int MAXN = 1000010;
int[] dp  = new int[MAXN];
int[] pre_max  = new int[MAXN];
int[] num  = new int[MAXN];

public static void main(String[] args) {
new P1024().run();
}

//dp[i][j]=Max(dp[i][j-1]+a[j] , max( dp[i-1][k] ) + a[j] ) 0<k<j
public void run(){
Scanner scanner = new Scanner(System.in);
int m, n;
while (scanner.hasNextInt()) {
m = scanner.nextInt();
n = scanner.nextInt();
int maxx =  -INF;
for (int i = 1; i <= n; i++) {
num[i] = scanner.nextInt();
dp[i] = 0;
pre_max[i] = 0;
}

dp[0] = 0;
pre_max[0] = 0;
for (int i = 1; i <= m; i++) {
maxx = -INF;
for (int j = i; j <= n; j++) {
dp[j] = Math.max(dp[j-1] + num[j], pre_max[j-1] + num[j]);
pre_max[j - 1] = maxx;
maxx = Math.max(maxx, dp[j]);
}
}
System.out.println(maxx);
}
scanner.close();
}

}


注:OJ上运行的时候将类名换成Main。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: