您的位置:首页 > 其它

POJ 1979 Red and Black

2015-09-20 18:46 381 查看
原题链接:http://poj.org/problem?id=1979

题目:

B - Red and Black
Time Limit:1000MS Memory Limit:30000KB 64bit IO Format:%I64d
& %I64

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0


Sample Output

45
59
6
13


题目大意:

在墙内,一个人最多可以移动多少格。

解题思路:

找到人所在的点,一个个遍历就好了。很简单的深搜题。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int tot = 1, m, n;
char rec[25][25];//保存地图
void DFS(int i, int j);
int main()
{
while(scanf("%d%d", &m, &n) != EOF && (m || n))
{
int  k = 0;
for(int i = 0; i < n; i++)
{
memset(rec[i], '\0', sizeof(rec[i]));
scanf("%s", rec[i]);
}

for(int i = 0; i < n; i++)
{
if(k)
break;
for(int j = 0; j < m; j++)
{
if(rec[i][j] == '@')
{
k = 1;
DFS(i, j);
break;
}
}
}
printf("%d\n", tot);
tot = 1;
}
return 0;
}

void DFS(int i, int j)//上下左右分别遍历
{
if(i - 1 >= 0 && rec[i-1][j] == '.')
{
tot++;
rec[i-1][j] = '0';//如果已经走过,则将该点赋值为‘0’.
DFS(i-1, j);
}

if(j - 1 >= 0 && rec[i][j-1] == '.')
{
rec[i][j-1] = '0';
tot++;
DFS(i, j-1);
}

if(i + 1 < n && rec[i+1][j] == '.')
{
rec[i+1][j] = '0';
tot++;
DFS(i+1, j);
}

if(j + 1 < m && rec[i][j+1] == '.')
{
rec[i][j+1] = '0';
tot++;
DFS(i, j+1);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: