您的位置:首页 > 其它

poj-2406-Power Strings(KMP)

2015-09-20 11:22 483 查看
Power Strings

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 38544 Accepted: 16001
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined
in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.

Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.

/*一个裸的KMP,最后判断一下是否循环*/
#include<stdio.h>
#include<string.h>
int p[1000010];
char str[1000010];
int len;
void getp()
{
int i=0,j=-1;
p[i]=-1;
while(i<len)
{
if(j==-1||str[i]==str[j])
{
i++,j++;
p[i]=j;
}
else
j=p[j];
}
}
int main()
{
while(scanf("%s",str)!=EOF)
{
memset(p,0,sizeof(p));
len=strlen(str);
getp();
if(strcmp(str,".")==0)
break;
if(len%(len-p[len])==0)
printf("%d\n",len/(len-p[len]));
else printf("1\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: