您的位置:首页 > 其它

Square Coins(母函数)

2015-09-20 11:21 495 查看

Square Coins

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9926 Accepted Submission(s): 6806


[align=left]Problem Description[/align]
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

[align=left]Input[/align]
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

[align=left]Output[/align]
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

[align=left]Sample Input[/align]

2 10 30 0

[align=left]Sample Output[/align]

1 4 27
题解:钱可以取多次,钱的面值是x^2,最大面值是17^2=289;母函数;
代码:

#include<stdio.h>
#include<math.h>
const int MAXN=310;
int main(){
int N,a[MAXN],b[MAXN];
while(~scanf("%d",&N),N){
for(int i=0;i<=N;i++)
a[i]=1,b[i]=0;
for(int i=2;i<=17;i++){//最大硬币值是289
for(int j=0;j<=N;j++)
for(int k=0;k+j<=N;k+=i*i)
b[j+k]+=a[j];
for(int j=0;j<=N;j++)
a[j]=b[j],b[j]=0;
}
printf("%d\n",a
);
}
return 0;
}


extern "C++"{
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
using namespace std;
const int INF = 0x3f3f3f3f;
#define mem(x,y) memset(x,y,sizeof(x))
typedef long long LL;
typedef unsigned long long ULL;

void SI(int &x){scanf("%d",&x);}
void SI(double &x){scanf("%lf",&x);}
void SI(LL &x){scanf("%lld",&x);}
void SI(char *x){scanf("%s",x);}

}
const int MAXN = 350;
int a[MAXN],b[MAXN];
int x[30];
int main(){
int N;
while(scanf("%d",&N),N){
for(int i = 0;i <= N;i++)a[i] = 1,b[i] = 0;
for(int i = 2;i <= 25;i++)x[i] = i * i;
for(int i = 2;x[i] <= N;i++){
for(int j = 0;j <= N;j++){
for(int k = 0;j + k <= N;k += x[i]){
b[j + k] += a[j];
}
}
for(int j = 0;j <= N;j++)a[j] = b[j],b[j] = 0;
}
printf("%d\n",a
);
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: