您的位置:首页 > 其它

POJ 1611 The Suspects

2015-09-20 09:55 302 查看


The Suspects

总时间限制: 1000ms 内存限制: 65536kB

描述

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.

In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects
the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).

Once a member in a group is a suspect, all members in the group are suspects.

However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

输入

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer
between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group.
Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.

A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

输出

For each case, output the number of suspects in one line.

样例输入
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0


样例输出
4
1
1


分析

本题属于并查集的一种,只需要合并后查元素0所在的几何的数目即可,也可以认为是求0所在的强连通图的结点数目。

代码
#include<iostream>
using namespace std;

int pre[50005], son[50005];

int find(int x)
{
    return x==pre[x]? x:find(pre[x]);
}

void merge(int x, int y)
{
    int root1, root2;
    root1 = find(x);
    root2 = find(y);
    if(root1 != root2)
    {
        pre[root2] = root1;
        son[root1] += son[root2];
    }
}

int main()
{
    int n, m;
    while(cin>>n>>m)
    {
        for(int i=0; i<n; i++)
        {
            pre[i] = i;  son[i] = 1;
        }
        while(m--)
        {
            int k;
            cin>>k;
            int *stu = new int[k];
            for(int i=0; i<k; i++)
            {
                cin>>stu[i];
                if(i!=0)
                    merge(stu[i-1], stu[i]);
            }
            delete stu;
        }
        cout<<son[find(0)]<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: