您的位置:首页 > 大数据 > 人工智能

Light oj 1138 - Trailing Zeroes (III)

2015-09-19 16:40 495 查看
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld
& %llu
Submit Status

Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero
on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5

Case 2: 10

Case 3: impossible

如果一个数的阶乘后有n个0,求出这个数最小是几.

附代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
long a,b,i,n,m,j,k,l,left,right,mid,ans;
int ac(long n)//函数 求出n的阶乘有多少个0
{
long ans=0;
while(n)
{
ans+=n/5;
n=n/5;
}
return ans;
}
int main()
{
int flag=1;
scanf("%ld",&k);
while(k--)
{
scanf("%ld",&n);
left=0;
right=5*n;
while(left<=right)
{
mid=(left+right)/2;
long num=ac(mid);
if(num>n)
right=mid-1;
else if(num<n)
left=mid+1;
if(num==n)
{
ans=mid;
right=mid-1;
}
}
if(ac(left)==n)
printf("Case %d: %ld\n",flag++,ans);
else
printf("Case %d: impossible\n",flag++);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数论 阶乘