您的位置:首页 > 其它

hdoj 1212Big Number(大数取模)

2015-09-19 11:09 357 查看

Big Number

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6148 Accepted Submission(s): 4295

[/b]

Problem Description
As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.



Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.



Output
For each test case, you have to ouput the result of A mod B.



Sample Input
2 3
12 7
152455856554521 3250




Sample Output
2
5
1521模板: [code]for(i=0;i<len;i++)
{
sum=(sum*10+(s[i]-'0')%m)%m;
}
代码: #include<stdio.h>
#include<string.h>
int main()
{
int i,m;
char s[1000];
while(scanf("%s%d",s,&m)!=EOF)
{
int sum=0;
int len=strlen(s);
for(i=0;i<len;i++)
{
sum=(sum*10+(s[i]-'0')%m)%m;
}
printf("%d\n",sum);
}

}[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: