您的位置:首页 > 其它

POJ 1847 Tram

2015-09-18 12:47 204 查看
Description:

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input:

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output:

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input:

3 2 1
2 2 3
2 3 1
2 1 2


Sample Output:

0

题意:有n个十字路口,每个十字路口有连着不同的轨道进入不同的十字路口,每个十字路口只有一个与之直接相连的路口,如果想要到其他路口去就必须手动控制,那么从路口A到路口B最少需要几次手动控制开关。先看一下输入,先输入n  A  B,这个不需要多解释,接下来n行,每行先输入一个x表示与路口i相连的路口有多少个,接下来x个数,表示与路口i相连的路口的编号y,值得注意的是输入的第一个y是本来就与路口i直接相连的,那么此时的G[i][y]=0,其他的y则需要手动控制了,那么此时的G[i][y]=1,感觉输入说完就不用再解释了,代码呼之欲出,直接用Floyd算法模板即可。

那就直接贴上代码了。。。


#include<stdio.h>
#include<queue>
#include<algorithm>
using namespace std;

const int N=110;
const int INF=0x3f3f3f3f;

int G

, n;

void Init()
{
int i, j;

for (i = 1; i <= n; i++)
{
for (j = 1; j <= n; j++)
G[i][j] = INF;
G[i][i] = 0;
}
}

void Dist()
{
int i, j, k;

for (k = 1; k <= n; k++)
{
for (i = 1; i <= n; i++)
{
for (j = 1; j <= n; j++)
G[i][j] = min(G[i][j], G[i][k]+G[k][j]);
}
}
}

int main ()
{
int A, B, i, j, x, y;

while (scanf("%d%d%d", &n, &A, &B) != EOF)
{
Init();

for (i = 1; i <= n; i++)
{
scanf("%d", &x);

for (j = 1; j <= x; j++)
{
scanf("%d", &y);

if (j == 1) G[i][y] = 0;
else G[i][y] = 1;
}
}

Dist();

if (G[A][B] == INF) printf("-1\n");
else printf("%d\n", G[A][B]);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: