您的位置:首页 > 其它

poj 2443

2015-09-17 00:56 363 查看
Set Operation

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 2961Accepted: 1192
Description

You are given N sets, the i-th set (represent by S(i)) have C(i) element (Here "set" isn't entirely the same as the "set" defined in mathematics, and a set may contain two same element). Every element in a set is represented by a positive number from 1 to 10000. Now there are some queries need to answer. A query is to determine whether two given elements i and j belong to at least one set at the same time. In another word, you should determine if there exist a number k (1 <= k <= N) such that element i belongs to S(k) and element j also belong to S(k).
Input

First line of input contains an integer N (1 <= N <= 1000), which represents the amount of sets. Then follow N lines. Each starts with a number C(i) (1 <= C(i) <= 10000), and then C(i) numbers, which are separated with a space, follow to give the element in the set (these C(i) numbers needn't be different from each other). The N + 2 line contains a number Q (1 <= Q <= 200000), representing the number of queries. Then follow Q lines. Each contains a pair of number i and j (1 <= i, j <= 10000, and i may equal to j), which describe the elements need to be answer.
Output

For each query, in a single line, if there exist such a number k, print "Yes"; otherwise print "No".
Sample Input

3
3 1 2 3
3 1 2 5
1 10
4
1 3
1 5
3 5
1 10

Sample Output

Yes
Yes
No
No

Hint

The input may be large, and the I/O functions (cin/cout) of C++ language may be a little too slow for this problem.

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<algorithm>
#include<string>
#include<vector>
using namespace std;
int n,m;
int a[32][10005];
int main()
{
int num,tt,q;
while(scanf("%d",&n)!=EOF)
{
bool flag;
memset(a,0,sizeof(a));
for(int i=0;i<n;i++)
{
scanf("%d",&num);
int xx,yy;
xx=i/32;
yy=i%32;
for(int j=0;j<num;j++)
{
scanf("%d",&tt);
a[xx][tt]|=(1<<yy);
}
}
m=n/32;
scanf("%d",&q);
for(int i=0;i<q;i++)
{
int u,v;
flag=false;
scanf("%d%d",&u,&v);
for(int j=0;j<=m;j++)
{
if(a[j][u]&a[j][v])
{
flag=1;
break;
}
}
if(flag)
printf("Yes\n");
else
printf("No\n");
}
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: