您的位置:首页 > 其它

1029 Ignatius and the Princess IV

2015-09-16 22:38 381 查看
Problem Description

"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?

Input

The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is
terminated by the end of file.

Output

For each test case, you have to output only one line which contains the special number you have found.

Sample Input

5
1 3 2 3 3
11
1 1 1 1 1 5 5 5 5 5 5
7
1 1 1 1 1 1 1


Sample Output

3
5
1


Author

Ignatius.L

因为该整数出现过(N+1)/2,又因为总数N为奇数,

所以将这N个排序,中间那个数就是特殊的数。

#include<iostream>
#include<algorithm>
using namespace std;
int a[1000000];

int main()
{
int i,N;
while(cin>>N)
{
for(i=0;i<N;i++)
{
cin>>a[i];
}
sort(a,a+N);
cout<<a[(N-1)/2]<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: