您的位置:首页 > 其它

2199 Can you solve this equation?

2015-09-16 21:23 253 查看
Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4


Sample Output

1.6152
No solution!


Author

Redow

二分查找题~

<span style="font-size:10px;">//HDOJ_2199
//20150916

#include<iostream>
#include<cmath>
#include<iomanip>
using namespace std;

double f(double x)
{
return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*pow(x,1)+6;
}

int main()
{
int T;
double Y,l,r,m;
cin>>T;
while(T--)
{
cin>>Y;
if(f(0)<=Y&&f(100)>=Y)
{
l=0;
r=100;
while(l-r<-1e-6)
{
m=(l+r)/2;
double ans=f(m);
if(ans>Y)
r=m-(1e-7);
else
l=m+(1e-7);
}
cout<<fixed<<setprecision(4)<<(l+r)/2<<endl;
}
else
cout<<"No solution!"<<endl;
}

}</span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: