您的位置:首页 > 其它

HDU - 2141 Can you find it?(二分查找)

2015-09-16 20:04 531 查看
Can you find it?

Time Limit: 3000MSMemory Limit: 10000KB64bit IO Format: %I64d & %I64u
Submit Status

Description

Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.



Input

There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent
the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.



Output

For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".



Sample Input

3 3 3
1 2 3
1 2 3
1 2 3
3
1
4
10




Sample Output

Case 1:
NO
YES
NO




#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int a[600], b[600], c[600];
int sum[300000];
int l, n, m;

bool binary_search(int x)
{
	int l = 0, r = n*m - 1, m;
	while (l <= r)
	{
		m = (l + r) >> 1;
		if (x == sum[m]) return true;
		if (x < sum[m]) r = m - 1;
		else l = m + 1;
	}
	return false;
}

int main()
{
	int cas = 1;
	while (scanf("%d%d%d", &l, &n, &m) != EOF)
	{
		for (int i = 0; i < l; i++)
			scanf("%d", &a[i]);
		for (int i = 0; i < n; i++)
			scanf("%d", &b[i]);
		for (int i = 0; i < m; i++)
			scanf("%d", &c[i]);

		int ji = 0;
		for (int i = 0; i < n; i++)
		for (int j = 0; j < m; j++)
			sum[ji++] = b[i] + c[j];

		sort(sum, sum + ji);

		int query, num;
		scanf("%d", &query);

		printf("Case %d:\n", cas++);

		for (int q = 0; q < query; q++)
		{
			scanf("%d", &num);
			bool ret = false;
			for (int i = 0; i < l; i++)
			{
				if (binary_search(num - a[i]))
				{
					ret = true;
					break;
				}
			}
			if (ret) printf("YES\n");
			else printf("NO\n");
		}
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: