您的位置:首页 > 其它

hdu5443 The Water Problem

2015-09-16 08:49 302 查看

The Water Problem

Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 602 Accepted Submission(s): 485


[align=left]Problem Description[/align]
In
Land waterless, water is a very limited resource. People always fight
for the biggest source of water. Given a sequence of water sources with a1,a2,a3,...,an representing the size of the water source. Given a set of queries each containing 2 integers l and r, please find out the biggest water source between al and ar.

[align=left]Input[/align]
First you are given an integer T(T≤10) indicating the number of test cases. For each test case, there is a number n(0≤n≤1000) on a line representing the number of water sources. n integers follow, respectively a1,a2,a3,...,an, and each integer is in {1,...,106}. On the next line, there is a number q(0≤q≤1000) representing the number of queries. After that, there will be q lines with two integers l and r(1≤l≤r≤n) indicating the range of which you should find out the biggest water source.

[align=left]Output[/align]
For each query, output an integer representing the size of the biggest water source.

[align=left]Sample Input[/align]

3
1
100
1
1 1
5
1 2 3 4 5
5
1 2
1 3
2 4
3 4
3 5
3
1 999999 1
4
1 1
1 2
2 3
3 3

[align=left]Sample Output[/align]

100
2
3
4
4
5
1
999999
999999
1

[align=left]Source[/align]
2015 ACM/ICPC Asia Regional Changchun Online

[align=left]Recommend[/align]
hujie | We have carefully selected several similar problems for you: 5449 5448 5447 5446 5445
区间求最大值
次裸裸的RMQ,套上模板即过

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<math.h>
#include<algorithm>
using namespace std;
#define N 50005
int dpmin
[20],dpmax
[20];
int main()
{
int t;
scanf("%d",&t);
while(t--){
int i, j, n, m;
scanf("%d",&n);
memset(dpmin,0,sizeof(dpmin));
memset(dpmax,0,sizeof(dpmax));
for(i=1; i<=n; i++)
{
scanf("%d", &dpmin[i][0]);
dpmax[i][0]=dpmin[i][0];
}
int mm=floor(log(1.0*n)/log(2.0));
for(j=1; j<=mm; j++)
for(i=1; i<=n; i++)
{
if((i+(1<<(j-1)))<=n)
{
//            dpmin[i][j]=min(dpmin[i][j-1], dpmin[i+(1<<(j-1))][j-1]);
dpmax[i][j]=max(dpmax[i][j-1], dpmax[i+(1<<(j-1))][j-1]);
}
}
int x, y;

scanf("%d",&m);
for(int i=1; i<=m; i++)
{
scanf("%d%d", &x, &y);
int  mid=floor(log(y*1.0-x+1)/log(2.0));
int maxnum=max(dpmax[x][mid], dpmax[y-(1<<mid)+1][mid]);
//    int minnum=min(dpmin[x][mid], dpmin[y-(1<<mid)+1][mid]);
printf("%d\n", maxnum);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: