您的位置:首页 > 其它

2386 Lake Counting【dfs】

2015-09-15 20:47 393 查看
Lake Counting

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24428 Accepted: 12334
Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure
out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.
Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.
Output

* Line 1: The number of ponds in Farmer John's field.
Sample Input
10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output
3

Hint

OUTPUT DETAILS: 

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

dfs 题目,直接无脑深搜......

#include<stdio.h>
char x[105][105];
int n,m;
void dfs(int a,int b)//搜索
{
if(a<0||a>=n||b<0||b>=m||x[a][b]=='.')
{
return ;
}
x[a][b]='.';
for(int i=-1;i<2;++i)//八个方向搜索...
{
for(int j=-1;j<2;++j)
{
dfs(a+i,b+j);
}
}
}
int main()
{
while(~scanf("%d%d",&n,&m))
{
for(int i=0;i<n;++i)
{
getchar();
for(int j=0;j<m;++j)
{
scanf("%c",&x[i][j]);
}
}
int cnt=0;
for(int i=0;i<n;++i)//查找
{
for(int j=0;j<m;++j)
{
if(x[i][j]=='W')
{
++cnt;
dfs(i,j);//搜
}
}
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: