您的位置:首页 > 其它

hdu 5444 Elven Postman 树的先序遍历 2015 ACM/ICPC Asia Regional Changchun Online

2015-09-14 12:18 441 查看


Elven Postman

Time Limit: 1500/1000 MS (Java/Others) Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 1108 Accepted Submission(s): 587



Problem Description

Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs
through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully
like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having
the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it
encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.





Input

First you are given an integer T(T≤10) indicating
the number of test cases.

For each test case, there is a number n(n≤1000) on
a line representing the number of rooms in this tree. n integers
representing the sequence written at the root follow, respectively a1,...,an where a1,...,an∈{1,...,n}.

On the next line, there is a number q representing
the number of mails to be sent. After that, there will be q integers x1,...,xq indicating
the destination room number of each mail.



Output

For each query, output a sequence of move (E or W)
the postman needs to make to deliver the mail. For that E means
that the postman should move up the eastern branch and W the
western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.



Sample Input

2
4
2 1 4 3
3
1 2 3
6
6 5 4 3 2 1
1
1




Sample Output

E

WE
EEEEE




#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
#include<climits>
#include<queue>
#include<vector>
#include<map>
#include<sstream>
#include<set>
#include<stack>
#include<utility>
#pragma comment(linker, "/STACK:102400000,102400000")
#define PI 3.1415926535897932384626
#define eps 1e-10
#define sqr(x) ((x)*(x))
#define FOR0(i,n)  for(int i=0 ;i<(n) ;i++)
#define FOR1(i,n)  for(int i=1 ;i<=(n) ;i++)
#define FORD(i,n)  for(int i=(n) ;i>=0 ;i--)
#define  lson   num<<1,le,mid
#define rson    num<<1|1,mid+1,ri
#define MID   int mid=(le+ri)>>1
#define zero(x)((x>0? x:-x)<1e-15)
#define mk    make_pair
#define _f     first
#define _s     second

using namespace std;
//const int INF=    ;
typedef long long ll;
//const ll inf =1000000000000000;//1e15;
//ifstream fin("input.txt");
//ofstream fout("output.txt");
//fin.close();
//fout.close();
//freopen("a.in","r",stdin);
//freopen("a.out","w",stdout);
const int INF =0x3f3f3f3f;
const int maxn= 1000+20   ;
//const int maxm=    ;
//by yskysker123
int n,m;
int G[maxn][2];
int a[maxn];
void build(int st,int ed )
{
    if(st>=ed)  return;
    int ri;
    for(ri=st+1;ri<=ed;ri++)
    {
        if(a[ri]>a[st])  break;
    }
    if(ri>st+1)
    {
        G[st][0]=st+1;
        build(st+1, ri-1);
    }
    if(ri<=ed)
    {
        G[st][1]=ri;
        build( ri,ed   );
    }

}

void get(int x,int des)
{
    if(des==a[x])
    {
         putchar('\n');
         return ;
    }

    if(des>a[x])
    {
         putchar('W');
         int y=G[x][1];
         get(y,des);
    }

    else
    {
         putchar('E');
          int y=G[x][0];
         get(y,des);
    }

}
int main()
{
    int T,des;
    scanf("%d",&T);
    while(T--)
    {
          scanf("%d",&n);

          memset(G,0,sizeof G);
          for(int i=1;i<=n;i++)
           scanf("%d",&a[i]);

          build(1,n);
          scanf("%d",&m);
             for(int i=1;i<=m;i++)
          {
               scanf("%d",&des);
               get(1,des);
          }
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: