您的位置:首页 > 其它

POJ 3617 Best Cow Line (字典序最小_贪心)

2015-09-13 21:05 489 查看
Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase
ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he's
finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N

* Lines 2..N+1: Line i+1 contains a single initial ('A'..'Z') of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input
6
A
C
D
B
C
B

Sample Output
ABCBCD


此题坑点在输出格式上,超出80个单词需要另起一行!!!! PE一发

#include<iostream>
#include<cstdio>
using namespace std;
char s[2222];
bool check(int l,int r)
{
while(l<=r) {
if(s[l]==s[r]) {
l++;
r--;
}
else if(s[l]>s[r]) return false;
else return true;
}
return true;
}

int main()
{
int i,j,l,r,n,sigh;
cin>>n;
sigh=0;
for(i=1;i<=n;i++) cin>>s[i];
l=1;r=n;
while(l<=r) {
if(s[l]<s[r]) cout<<s[l++];
else if(s[l]>s[r]) cout<<s[r--];
else {
if(check(l,r)) cout<<s[l++];
else cout<<s[r--];
}
sigh++;
if(sigh==80) {
cout<<endl;
sigh=0;
}
}
cout<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: