您的位置:首页 > 其它

hdu 5437 Alisha’s Party 模拟 优先队列

2015-09-13 20:11 405 查看
[align=left]Problem Description[/align]
Princess Alisha invites her friends to come to her birthday party. Each of her friends will bring a gift of some value v, and all of them will come at a different time. Because the lobby is not large enough, Alisha can only let a few people in at a time. She decides to let the person whose gift has the highest value enter first.

Each time when Alisha opens the door, she can decide to let p people enter her castle. If there are less than p people in the lobby, then all of them would enter. And after all of her friends has arrived, Alisha will open the door again and this time every friend who has not entered yet would enter.

If there are two friends who bring gifts of the same value, then the one who comes first should enter first. Given a query n Please tell Alisha who the n−th person to enter her castle is.

[align=left]Input[/align]
The first line of the input gives the number of test cases, T , where 1≤T≤15.

In each test case, the first line contains three numbers k,m and q separated by blanks. k is the number of her friends invited where 1≤k≤150,000. The door would open m times before all Alisha’s friends arrive where 0≤m≤k. Alisha will have q queries where 1≤q≤100.

The i−th of the following k lines gives a string Bi, which consists of no more than 200 English characters, and an integer vi, 1≤vi≤108, separated by a blank.Bi is the name of the i−th person coming to Alisha’s party and Bi brings a gift of value vi.

Each of the following m lines contains two integers t(1≤t≤k) and p(0≤p≤k) separated by a blank. The door will open right after the t−th person arrives, and Alisha will let p friends enter her castle.

The last line of each test case will contain q numbers n1,...,nq separated by a space, which means Alisha wants to know who are the n1−th,...,nq−th friends to enter her castle.

Note: there will be at most two test cases containing n>10000.

[align=left]Output[/align]
For each test case, output the corresponding name of Alisha’s query, separated by a space.

[align=left]Sample Input[/align]

1

5 2 3
Sorey 3

Rose 3

Maltran 3
Lailah 5

Mikleo 6

1 1
4 2

1 2 3

[align=left]Sample Output[/align]

Sorey Lailah Rose

[align=left]Source[/align]
2015 ACM/ICPC Asia Regional Changchun Online

本来是一道简单的模拟题,我却花了很久的时间,一直wa,要跪了
后来还是请教了别人才知道错在哪里了
数据的时间是没有说是有序的,也就是时间的数据不一定是按照顺序给我们的。
所以要先对数据进行排序。

以后要时刻记住,输入数据一定要考虑乱序的情况。

#include<cstdio>
#include<cstring>
#include<queue>
#include<algorithm>

#define pb push_back

using namespace std;

const int maxn=150000+5;

struct Node
{
int v,id;
bool operator <(const Node&x)const
{
if(x.v==v)
return x.id<id;
return v<x.v;
}
};
struct Time
{
int tim,num;
};
Time time[maxn];
char name[maxn][205];
Node ord[maxn];
int ans[maxn];

bool cmp(Time x,Time y)
{
return x.tim<y.tim;
}

priority_queue<Node>que;

int main()
{
int test;
scanf("%d",&test);
while(test--){
int n,m,q;
scanf("%d %d %d",&n,&m,&q);
for(int i=0;i<n;i++){
scanf("%s %d",&name[i],&ord[i].v);
ord[i].id=i;
}

for(int i=0;i<m;i++){
scanf("%d %d",&time[i].tim,&time[i].num);
}

sort(time,time+m,cmp);

while(!que.empty())
que.pop();

int now=0,len=0;
for(int j=0;j<m;j++){
while(now<time[j].tim){
que.push(ord[now]);
now++;
}
while(time[j].num--){
ans[len++]=que.top().id;
que.pop();
if(que.empty())
break;
}
}
while(now<n){
que.push(ord[now++]);
}
while(!que.empty()){
ans[len++]=que.top().id;
que.pop();
}
int c;
for(int i=0;i<q-1;i++){
scanf("%d",&c);
printf("%s ",name[ans[c-1]]);
}
scanf("%d",&c);
printf("%s\n",name[ans[c-1]]);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: