您的位置:首页 > 其它

HDU 5375 Gray code

2015-09-12 17:00 253 查看


Gray code

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 904 Accepted Submission(s): 510



Problem Description
The reflected binary code, also known as Gray code after Frank Gray, is a binary numeral system where two successive values differ in only onebit (binary digit). The reflected binary code was originally designed to prevent spurious
output from electromechanical switches. Today, Gray codes are widely used to facilitate error correction in digital communications such as digital terrestrial television and some cable TV systems.



Now , you are given a binary number of length n including ‘0’ , ’1’ and ‘?’(? means that you can use either 0 or 1 to fill this position) and n integers(a1,a2,….,an) . A certain binary number corresponds to a gray code only. If the ith bit of this gray code
is 1,you can get the point ai.

Can you tell me how many points you can get at most?

For instance, the binary number “00?0” may be “0000” or “0010”,and the corresponding gray code are “0000” or “0011”.You can choose “0000” getting nothing or “0011” getting the point a3 and a4.



Input
The first line of the input contains the number of test cases T.

Each test case begins with string with ‘0’,’1’ and ‘?’.

The next line contains n (1<=n<=200000) integers (n is the length of the string).

a1 a2 a3 … an (1<=ai<=1000)



Output
For each test case, output “Case #x: ans”, in which x is the case number counted from one,’ans’ is the points you can get at most


Sample Input
2
00?0
1 2 4 8
????
1 2 4 8




Sample Output
Case #1: 12
Case #2: 15
Hint https://en.wikipedia.org/wiki/Gray_code  http://baike.baidu.com/view/358724.htm




Author
UESTC


Source
2015 Multi-University Training Contest 7



Recommend
输入是二进制的,能转换成格雷码,若格雷码对应位是1,那么就能取到这一位对应的值,求输入情况中,能取得最大值。这是一个DP题,DP[i][j]表示第I位取1或者0,所以,dp[i][0] = dp[i-1][1]+num[i],应为如果二进制中,I和I-1不相等,那么格雷码这一位就是1,就要取值。

#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
using namespace std;
#define ll long long

ll num[200010];
ll dp[200010][2];
int main()
{
	ll T;
	cin >> T;
	ll g = 1;
	while(T--)
	{
		printf("Case #%lld: ",g++);
		string s;
		cin >> s;
		for(int i=0;i<s.length();i++)
		scanf("%lld",&num[i]);
		memset(dp,0,sizeof(dp));
		if(s[0]=='1'||s[0]=='?')dp[0][1] = num[0];
		for(int i=1;i<s.length();i++)
		{
			if (s[i - 1] == '?')
			{
				if (s[i] == '?')
				{
					dp[i][0] = max(dp[i - 1][0], dp[i - 1][1] + num[i]);
					dp[i][1] = max(dp[i - 1][1], dp[i - 1][0] + num[i]);
				}
				else if (s[i] == '0')
					dp[i][0] = max(dp[i - 1][0], dp[i - 1][1] + num[i]);
				else
					dp[i][1] = max(dp[i - 1][1], dp[i - 1][0] + num[i]);
			}
			else if (s[i - 1] == '0')
			{
				if (s[i] == '?')
				{
					dp[i][0] = dp[i - 1][0];
					dp[i][1] = dp[i - 1][0] + num[i];
				}
				else if (s[i] == '0')
					dp[i][0] = dp[i - 1][0];
				else
					dp[i][1] = dp[i - 1][0] + num[i];
			}
			else
			{
				if (s[i] == '?')
				{
					dp[i][0] = dp[i - 1][1]+num[i];
					dp[i][1] = dp[i - 1][1] ;
				}
				else if (s[i] == '0')
					dp[i][0] = dp[i - 1][1]+num[i];
				else
					dp[i][1] = dp[i - 1][1];
			}
		}
		cout<<max(dp[s.length()-1][0],dp[s.length()-1][1])<<endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: