您的位置:首页 > 其它

uva 213

2015-09-11 15:40 309 查看
原题:

Some message encoding schemes require that an encoded message be sent in two parts. The first part,

called the header, contains the characters of the message. The second part contains a pattern that

represents the message. You must write a program that can decode messages under such a scheme.

The heart of the encoding scheme for your program is a sequence of “key” strings of 0’s and 1’s as

follows:

0,00,01,10,000,001,010,011,100,101,110,0000,0001,...,1011,1110,00000,...

The first key in the sequence is of length 1, the next 3 are of length 2, the next 7 of length 3, the

next 15 of length 4, etc. If two adjacent keys have the same length, the second can be obtained from

the first by adding 1 (base 2). Notice that there are no keys in the sequence that consist only of 1’s.

The keys are mapped to the characters in the header in order. That is, the first key (0) is mapped

to the first character in the header, the second key (00) to the second character in the header, the kth

key is mapped to the kth character in the header. For example, suppose the header is:

AB#TANCnrtXc

Then 0 is mapped to A, 00 to B, 01 to #, 10 to T, 000 to A, ..., 110 to X, and 0000 to c.

The encoded message contains only 0’s and 1’s and possibly carriage returns, which are to be ignored.

The message is divided into segments. The first 3 digits of a segment give the binary representation

of the length of the keys in the segment. For example, if the first 3 digits are 010, then the remainder

of the segment consists of keys of length 2 (00, 01, or 10). The end of the segment is a string of 1’s

which is the same length as the length of the keys in the segment. So a segment of keys of length 2 is

terminated by 11. The entire encoded message is terminated by 000 (which would signify a segment

in which the keys have length 0). The message is decoded by translating the keys in the segments

one-at-a-time into the header characters to which they have been mapped.

Input

The input file contains several data sets. Each data set consists of a header, which is on a single line

by itself, and a message, which may extend over several lines. The length of the header is limited

only by the fact that key strings have a maximum length of 7 (111 in binary). If there are multiple

copies of a character in a header, then several keys will map to that character. The encoded message

contains only 0’s and 1’s, and it is a legitimate encoding according to the described scheme. That is,

the message segments begin with the 3-digit length sequence and end with the appropriate sequence of

1’s. The keys in any given segment are all of the same length, and they all correspond to characters in

the header. The message is terminated by 000.

Carriage returns may appear anywhere within the message part. They are not to be considered as

part of the message.

Output

For each data set, your program must write its decoded message on a separate line. There should not

be blank lines between messages.

Sample input

TNM AEIOU

0010101100011

1010001001110110011

11000

$#**\

0100000101101100011100101000

Sample output

TAN ME
##*\$

题意大概是有一种编码方式用二进制表示, 首先输入一个编码头, 编码头中的每一个字符分别对应二进制序列( 0, 00, 01, 10, 000, 001, 010, .... ,0000, 0001, 0010, ... )

接下来是编码文本(可能由多行组成, 则直接把它们拼成一行), 分为多个小节, 每个小节的前三个数字代表该小节每个编码的长度(如100代表该小节每个Code长度为4), 

然后是各个字符的编码, 小节以全1结束. 整个信息以000开头的小节为结束标志

AC代码如下

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <string>
#include <cstring>
#include <cmath>
#include <vector>
#include <set>
#include <queue>
#include <map>
using namespace std;
const int MAXN = 20+2;
typedef long long LL;

char Map[8][1<<8];

int readlen(){
char ch;
int len = 0, i = 0;
while( i<3 ){
if( !isdigit(ch=getchar()) ) continue;
if( ch=='1' ){
len += pow(2,2-i);
}
i++;
}
return len;
}

char readcode(int len){
int i = 0, code = 0;
char ch;
while( i<len ){
if( !isdigit(ch=getchar()) ) continue;
if( ch=='1' ){
code += pow(2,len-1-i);
}
i++;
}
return Map[len][code];
}

int main(){
string header, output;
while( getline(cin,header)!=NULL ){
if( header.length()==0 ) continue;
memset(Map,0,sizeof(Map));
int len,val;
output.clear();
char ch;
val = 0;
len = 1;
for(int i=0; i<header.length(); i++){
if( val==pow(2,len)-1 ){
Map[len][val] = '\0';
len++;
val = 0;
}
Map[len][val] = header.at(i);
val++;
}
while( (len=readlen()) != 0 ){
while( (ch=readcode(len))!='\0' ){
output.push_back(ch);
}
}
cout << output << endl;
header.clear();
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: