您的位置:首页 > 其它

hdu 1075 What Are You Talking About(字典树)

2015-09-10 18:42 585 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1075


What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)

Total Submission(s): 17509    Accepted Submission(s): 5696


Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help
him?

 

 

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains
two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single
line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new
word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single
string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

 

 

Output

In this problem, you have to output the translation of the history book.

 

 

Sample Input

START
from fiwo
hello difh
mars riwosf
earth fnnvk
like fiiwj
END
START
difh, i'm fiwo riwosf.
i fiiwj fnnvk!
END

 

 

Sample Output

hello, i'm from mars.
i like earth!
 

Hint
Huge input, scanf is recommended.

 

题目大意:将给出的火星字符串翻译成英文字符串,每个单词有对应的英文单词,如果不存在对应的就输出原有的即可。

解题思路:对火星字符串进行建树,在最后一个字母上存下对应的英文字符串。这里要注意一个标记,不然会超内存。

如图。

画了两个具体说明一下,其余的以此类推。

详见代码。

#include <iostream>
#include <cstdio>
#include <cstring>
#include<malloc.h>

using namespace std;

struct node
{
char *cc;//用来存最后一个单词
node *next[26];
int flag;//用来标记
node()//初始化
{
for (int i=0; i<26; i++)
{
next[i]=NULL;
}
flag=0;
}
};

node *p,*root=new node();
void insert(char *s,char *t)//对火星文进行建树,在最后一个字符下面存下对应的英文字符串
{
p=root;
for (int i=0; s[i]!='\0'; i++)
{
int k=s[i]-'a';
if (p->next[k]==NULL)
p->next[k]=new node();
p=p->next[k];
}
p->flag=1;//用来标记当前火星字符串的结尾有对应的英文字符串
p->cc=(char*)malloc((strlen(t)+1)*sizeof(char));//申请动态空间
strcpy(p->cc,t);//将对应字符串存下
}

void Search(char *s)
{
p=root;
if(strlen(s)==0)
return ;
for (int i=0; s[i]!='\0'; i++)
{
int k=s[i]-'a';
if (p->next[k]==NULL)
{
printf("%s",s);//把原有字母输出(寻找的字符串不存在的,也就是未全部找完)
return;
}
p=p->next[k];
}
if (p->flag)
printf ("%s",p->cc);//输出找到的对应的单词
else
printf ("%s",s);//特殊判断找不到的情况,把原有字母输出(全部找完仍没有对应的)
}

int main()
{
char str[15],ch1[3010],ch2[3010];
char ch[3010];
scanf("%s",&str);
while (~scanf("%s",&ch1))
{
if (strcmp(ch1,"END")!=0)
{
scanf("%s",&ch2);
insert(ch2,ch1);
}
else
break;
}
scanf("%s",&str);
getchar();
while (gets(ch1))
{
if (strcmp(ch1,"END")==0)
break;
int k=0;
// cout<<111111111<<endl;
for(int i=0; ch1[i]!='\0'; i++)
{
if(ch1[i]>'z'||ch1[i]<'a')//将需要判断的字符串分割成一小部分一小部分
{
//cout<<"333333"<<ch1[i]<<endl;
ch[k]='\0';//找到一个就断开
Search(ch);//寻找相应的对应单词
printf("%c",ch1[i]);//输出断点的字符
k=0;//覆盖已经找过的字符,从头一个个存下来
}
else
{
ch[k++]=ch1[i];// 将符合条件的字符存下来
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: