您的位置:首页 > 其它

UVA 591 Box of Bricks

2015-09-09 18:40 513 查看
Description





Little Bob likes playing with his box of bricks. He puts the bricks one upon another and builds stacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you should make
all stacks the same height. Then you would have a real wall.'', she retorts. After a little con- sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that all stacks are the same height afterwards. But since Bob
is lazy he wants to do this with the minimum number of bricks moved. Can you help?



Input

The input consists of several data sets. Each set begins with a line containing the number n of stacks Bob has built. The next line containsn numbers, the heights hi of the n stacks. You may assume

and

.
The total number of bricks will be divisible by the number of stacks. Thus, it is always possible to rearrange the bricks such that all stacks have the same height.
The input is terminated by a set starting with n = 0. This set should not be processed.

Output

For each set, first print the number of the set, as shown in the sample output. Then print the line `` The minimum number of moves isk.'', where k is the minimum number of bricks that have to be moved in order to make all the stacks
the same height.
Output a blank line after each set.

Sample Input

6
5 2 4 1 7 5
0


Sample Output

Set #1
The minimum number of moves is 5.


Miguel A. Revilla

1998-03-10

答案:
#include <iostream>
#include <stdio.h>

using namespace std;
int main () {
int n, term = 0, count = 0;
int sum[55] = {0};
while (scanf("%d", &n) != EOF && n) {
count = 0;
int temp = 0;
term++;
printf("Set #%d\n", term);
for (int i = 0; i < n; i++) {
scanf("%d", &sum[i]);
temp = temp + sum[i];
}
int t;
t = temp / n;
for (int i = 0; i < n; i++) {
if (sum[i] > t)
count = sum[i] - t + count;
}
printf("The minimum number of moves is %d.\n", count);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: