您的位置:首页 > 其它

HDU 4336 Card Collector (容斥 期望)

2015-09-09 12:24 411 查看

Card Collector

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 3429 Accepted Submission(s): 1670

Special Judge

Problem Description
In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing
award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.

Input
The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ...
+ pN <= 1), indicating the possibility of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.

Output
Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.

Sample Input
1
0.1
2
0.1 0.4


Sample Output
10.000
10.500



Source
2012 Multi-University Training Contest 4

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4336

题目大意:n张卡片,每张卡片有pi的概率出现在每个盒子里,每个盒子里最多有一张卡片,现在求收集完n个卡片需要买的盒子的期望数

题目分析:首先每张卡片被收集是独立的,由于n只有20,可以状态压缩,已知一个事件在某个活动里发生的概率为p,则这个事件第一次发生需要的活动期望数为1/p,将每张卡片是否收集到这一事件压缩,比如001,表示第一张卡片已经收集到了,但是这里会重复计算,比如101时,第一张卡片的期望值又被算了一遍,因此要容斥一下即:

ans = 1/p1 + 1/p2 + .. + 1/pn - 1/(p1+p2) - 1/(p1+p3) - ... + 1/(p1+p2+p3) ...

#include <cstdio>
#include <cstring>
double p[25];

int main()
{
	int n;
	while(scanf("%d", &n) != EOF)
	{	
		memset(p, 0, sizeof(p));
		for(int i = 0; i < n; i++)
			scanf("%lf", &p[i]);
		double ans = 0;
		for(int i = 1; i < (1 << n); i++)
		{
			int cnt = 0;
			double tmp = 0;
			for(int j = 0; j < n; j++)
			{
				if(i & (1 << j))	
				{
					cnt ++;
					tmp += p[j];
				}
			}
			ans += (cnt & 1) ? (1.0 / tmp) : -(1.0 / tmp);
		}
		printf("%.6f\n", ans);
	}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: