您的位置:首页 > 其它

1092. To Buy or Not to Buy (20)

2015-09-08 22:40 387 查看
题目链接:http://www.patest.cn/contests/pat-a-practise/1092
题目:

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether
a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is "Yes", please tell her the number of extra beads she has to buy; or if the answer is "No", please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary
beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.



Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is "Yes", then also output the number of extra beads Eva has to buy; or if the answer is "No", then also output the number of beads missing from the string. There must be exactly 1 space between
the answer and the number.
Sample Input 1:
ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:
Yes 8

Sample Input 2:
ppRYYGrrYB225
YrR8RrY

Sample Output 1:
No 2


分析:

看一下店主中的颜色和数量是否够买,
因为题中的例子的问题,刚开始误解了题意了,以为是要买一种颜色的话一定要把这种颜色所有的珠子都买光。
其实,是要如果店主的颜色够的话就把整串都买来,并且输出多买的。

AC代码:
#include<cstdio>
#include<iostream>
#include<vector>
#include<algorithm>
#include<queue>
#include<stack>
#include<string>
#include<string.h>
using namespace std;
int main(){
 freopen("F://Temp/input.txt", "r", stdin);
 string boss;
 string Eva;
 cin >> boss >> Eva;
 int colors_boss[128];
 int colors_eva[128];
 memset(colors_eva, 0, sizeof(colors_eva));
 memset(colors_boss, 0, sizeof(colors_boss));
 for (int i = 0; i < Eva.size(); ++i){
  ++colors_eva[int(Eva[i])];
 }
 for (int i = 0; i < boss.size(); ++i){
   ++colors_boss[int(boss[i])];//
 }
 int negative = 0, positive = 0;
 for (int i = 0; i < 128; ++i){
  if (colors_eva[i] <= colors_boss[i])
   positive += colors_boss[i] - colors_eva[i];//
  else
   negative += colors_eva[i] - colors_boss[i];
 }
 if (negative > 0)
  cout << "No " << negative << endl;
 else
  cout << "Yes " << positive << endl;
 return 0;
}


截图:



——Apie陈小旭
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: