您的位置:首页 > 其它

POJ 3045 Cow Acrobats(贪心 or 二分)

2015-09-07 23:22 429 查看
题意:输入n头牛,每头牛有w重量和s力量两个属性,现在把牛摞成一串(竖着),一头牛踩在另一头牛身上,每头牛就会有一个危险指数,危险指数的计算方式是 这头牛的上面所有牛的重量的和(不包括这头牛本身的重量)减去这头牛的力量s,求在最小危险值的情况下, 危险最大的那头牛的危险值。

解题思路:贪心排下序,直观上重量和力量大的牛优先安排在尽可能靠下的位置。

本题也有二分的方法。

Description

Farmer John's N (1 <= N <= 50,000) cows (numbered 1..N) are planning to run away and join the circus. Their hoofed feet prevent them from tightrope walking and swinging from the trapeze (and their last attempt at firing a cow out of a cannon met with a dismal
failure). Thus, they have decided to practice performing acrobatic stunts.

The cows aren't terribly creative and have only come up with one acrobatic stunt: standing on top of each other to form a vertical stack of some height. The cows are trying to figure out the order in which they should arrange themselves ithin this stack.

Each of the N cows has an associated weight (1 <= W_i <= 10,000) and strength (1 <= S_i <= 1,000,000,000). The risk of a cow collapsing is equal to the combined weight of all cows on top of her (not including her own weight, of course) minus her strength (so
that a stronger cow has a lower risk). Your task is to determine an ordering of the cows that minimizes the greatest risk of collapse for any of the cows.

Input

* Line 1: A single line with the integer N.

* Lines 2..N+1: Line i+1 describes cow i with two space-separated integers, W_i and S_i.

Output

* Line 1: A single integer, giving the largest risk of all the cows in any optimal ordering that minimizes the risk.

Sample Input

3
10 3
2 5
3 3


Sample Output

2


Hint

OUTPUT DETAILS:

Put the cow with weight 10 on the bottom. She will carry the other two cows, so the risk of her collapsing is 2+3-3=2. The other cows have lower risk of collapsing.

Memory: 1092 KBTime: 47 MS
Language: G++Result: Accepted
#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<cctype>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>

using namespace std;

#define FOR(i, s, t) for(int i = (s) ; i <= (t) ; ++i)
#define REP(i, n) for(int i = 0 ; i < (n) ; ++i)

int buf[10];
inline long long read()
{
    long long x=0,f=1;
    char ch=getchar();
    while(ch<'0'||ch>'9')
    {
        if(ch=='-')f=-1;
        ch=getchar();
    }
    while(ch>='0'&&ch<='9')
    {
        x=x*10+ch-'0';
        ch=getchar();
    }
    return x*f;
}

inline void writenum(int i)
{
    int p = 0;
    if(i == 0) p++;
    else while(i)
        {
            buf[p++] = i % 10;
            i /= 10;
        }
    for(int j = p - 1 ; j >= 0 ; --j) putchar('0' + buf[j]);
}
/**************************************************************/
#define MAX_N 50005
const int INF = 0x3f3f3f3f;
struct node
{
    int s, w;
}a[MAX_N];

bool cmp(node a, node b)
{
    return a.s + a.w > b.s + b.w;
}
int n;
int main()
{
    while(~scanf("%d", &n))
    {
        int sum = 0;
        for(int i = 0 ; i < n ; i++)
        {
            a[i].w = read();
            a[i].s = read();
            sum += a[i].w;
        }
        sort(a, a + n, cmp);
        int ans = -INF;
        for(int i = 0 ; i < n ; i++)
        {
            sum -= a[i].w;
            ans = max(ans, sum - a[i].s);
        }
        printf("%d\n", ans);
    }

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: