您的位置:首页 > 其它

poj 1258 Agri-Net 最小生成树

2015-09-07 23:05 375 查看
Agri-Net

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 45755Accepted: 18837
Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.

The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines
of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output
28

Source

USACO 102

(排序)贪心+并查集
<pre name="code" class="cpp">#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
#define N 105
int a
,q,n;
struct point
{
	int x, y, v;
}eg[N*N];
bool cmp(const point &x1, const point &x2)
{
	return x1.v < x2.v;
}
int find(int x)
{
	while (x != a[x])
		x = a[x];
	return x;
}
void unio(int x1, int x2)
{
	int y1 = find(x1);
	int y2 = find(x2);
	if (y1 != a[y2])
		a[y2] = y1;
}
void kruskal()
{
	int ans = 0;
	for (int i = 1; i <= n; i++)
		a[i] = i;
	for (int i = 0; i <=q; i++)
	{
		if (find(eg[i].x) != find(eg[i].y))
		{
			unio(eg[i].x, eg[i].y);
			ans += eg[i].v;
		}
	}
	printf("%d\n", ans);
}
int main()
{
#ifdef CDZSC
	freopen("i.txt", "r",stdin);
#endif
	int x;
	while (~scanf("%d", &n)&&n)
	{
		q = -1;
		for (int i = 1; i <= n; i++)
		{
			for (int j = 1; j <= n; j++)
			{
				scanf("%d", &x);
					eg[++q].x = i;
					eg[q].y = j;
					eg[q].v = x;
			}
		}
		sort(eg, eg + q+1, cmp);
		kruskal();
	}
	return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: