您的位置:首页 > 其它

1076. Forwards on Weibo (30)

2015-09-07 18:40 337 查看
题目链接:http://www.patest.cn/contests/pat-a-practise/1076
题目:

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view
and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are
counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered
from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated
by a space.

Then finally a positive K is given, followed by K UserID's for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are
counted.
Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:
4
5


分析:

AC代码:
#include<stdio.h> 
#include<iostream> 
#include<vector> 
#include<queue> 
using namespace std; 
struct People{ 
 int id; 
 vector<int>fans; 
 int level; 
 People(){ 
  id = -1; 
  level = -1; 
  fans.clear(); 
 } 
}buf[1002]; 
queue<People*>Q; 
int fansCount(int level){ //fans树的广度搜索
 int ret_count = 0; 
 while (!Q.empty()){ 
  int idx = Q.front()->id; 
  Q.pop(); 
  if (buf[idx].level == level)return ret_count; 
  else{ 
   for (int i = 0; i < buf[idx].fans.size(); i++){ 
    if (buf[buf[idx].fans[i]].level == -1){ 
     buf[buf[idx].fans[i]].level = buf[idx].level + 1; 
     Q.push(&buf[buf[idx].fans[i]]); 
     ret_count++; 
    } 
   } 
  } 
 } 
 return ret_count; //就少了这一句,就有了两个案例过不去,主要是有没有粉丝出现达不到指定层级的情况。
}
int main(void){ 
 freopen("F://Temp/input.txt", "r", stdin); 
 int N, L; 
 cin >> N >> L; 
 for (int i = 1; i <= N; i++){ 
  buf[i].id = i; 
 } 
 for (int i = 1; i <= N; i++){ 
  int number; 
  cin >> number; 
  while (number--){ 
   int idol; 
   cin >> idol; 
   buf[idol].fans.push_back(buf[i].id); 
  } 
 } 
 int query_num; 
 cin >> query_num; 
 while (query_num--){ 
  while (!Q.empty())Q.pop(); 
  for (int i = 1; i <= N; i++){ 
   buf[i].level = -1; 
  } 
  int query; 
  int count = 0; 
  cin >> query; 
  buf[query].level = 0; 
  Q.push(&buf[query]); 
  count = fansCount(L); 
  cout << count << endl; 
 } 
 return 0; 
}


截图:



——Apie陈小旭
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: