您的位置:首页 > 其它

hdu3555(数位dp)

2015-09-07 11:08 253 查看

Bomb

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)

Total Submission(s): 10986 Accepted Submission(s): 3900



Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the
power of the blast would add one point.

Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output
For each test case, output an integer indicating the final points of the power.

Sample Input
3
1
50
500


Sample Output
0
1
15

HintFrom 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.


Author
fatboy_cw@WHU

Source
2010 ACM-ICPC Multi-University Training Contest(12)——Host
by WHU

分析:和hdu2089基本相同

#include <iostream>
#include <cstdio>
#include <cstring>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <cmath>
#include <algorithm>
using namespace std;
const double eps = 1e-6;
const double pi = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int MOD = 1000000007;
#define ll long long
#define CL(a) memset(a,0,sizeof(a))

ll dp[35][3];

ll slove(ll x)
{
    ll ans=0,k=0;
    int s[35];
    bool flag=false;
    while (x)
    {
        s[++k]=x%10;
        x/=10;
    }
    s[k+1]=0;
    for (int i=k; i>0; i--)
    {
        //cout<<ans<<endl;
        ans+=dp[i-1][2]*s[i];
        if (flag) ans+=dp[i-1][0]*s[i];
        if (!flag&&s[i]>4) ans+=dp[i-1][1];
        if (s[i+1]==4&&s[i]==9) flag=true;
    }
    return ans;
}

int main ()
{
    CL(dp);
    dp[0][0]=1;
    for (int i=1; i<23; i++)
    {
        dp[i][0] = dp[i-1][0]*10-dp[i-1][1];//没有49的情况
        dp[i][1] = dp[i-1][0];//没49的情况后补4
        dp[i][2] = dp[i-1][2]*10+dp[i-1][1];//有49的情况
    }
    int T;
    ll n;
    scanf ("%d",&T);
    while (T--)
    {
        scanf ("%lld",&n);
        if (n<49)
        {
            printf ("0\n");
            continue;
        }
        printf ("%lld\n",slove(n+1));
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: