您的位置:首页 > 其它

POJ2187Beauty Contes【凸包Graham+旋转卡壳求凸包直径+排除共线】

2015-09-06 16:36 281 查看
Language:
Default

Beauty Contest

Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 31323 Accepted: 9713
Description

Bessie, Farmer John's prize cow, has just won first place in a bovine beauty contest, earning the title 'Miss Cow World'. As a result, Bessie will make a tour of N (2 <= N <= 50,000) farms around the world in order to spread goodwill between farmers and their
cows. For simplicity, the world will be represented as a two-dimensional plane, where each farm is located at a pair of integer coordinates (x,y), each having a value in the range -10,000 ... 10,000. No two farms share the same pair of coordinates. 

Even though Bessie travels directly in a straight line between pairs of farms, the distance between some farms can be quite large, so she wants to bring a suitcase full of hay with her so she has enough food to eat on each leg of her journey. Since Bessie refills
her suitcase at every farm she visits, she wants to determine the maximum possible distance she might need to travel so she knows the size of suitcase she must bring.Help Bessie by computing the maximum distance among all pairs of farms. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Two space-separated integers x and y specifying coordinate of each farm 

Output

* Line 1: A single integer that is the squared distance between the pair of farms that are farthest apart from each other. 

Sample Input
4
0 0
0 1
1 1
1 0

Sample Output
2


题意:给出一些点求任意两点距离的最大值旋转卡壳求凸包直径注意排除共线

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std;
struct point{
int x,y;
}A[50010],result[50010];
long long MAX(long long a,long long b){
return a>b?a:b;
}
int cp(point p1,point p2,point p3){
return (p3.x-p1.x)*(p2.y-p1.y)-(p3.y-p1.y)*(p2.x-p1.x);
}
long long dist(point a,point b){
return (a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y);
}
bool cmp(point a,point b){
int ans=cp(A[0],a,b);
if(ans==0)
return dist(A[0],a)-dist(A[0],b)<=0;
return ans>0;
}
long long rotating_calipers(int top){//旋转卡壳
int q=1;
long long ans=0;
result[top]=result[0];
for(int i=0;i<top;++i){
while(cp(result[i+1],result[q+1],result[i])>cp(result[i+1],result[q],result[i]))
q=(q+1)%top;
ans=MAX(ans,MAX(dist(result[q],result[i]),dist(result[q+1],result[i+1])));
}
return ans;
}
int main()
{
int n,i,j,k;
while(scanf("%d",&n)!=EOF){
int pos=0;
for(i=0;i<n;++i){
scanf("%d%d",&A[i].x,&A[i].y);
if(A[pos].y>=A[i].y){
if(A[pos].y==A[i].y){
if(A[pos].x>A[i].x)pos=i;
}
else pos=i;
}
}
point temp;int top=1;
temp=A[0];A[0]=A[pos];A[pos]=temp;
sort(A+1,A+n,cmp);
result[0]=A[0];result[1]=A[1];
for(i=2;i<n;++i){
while(top&&cp(result[top-1],result[top],A[i])<=0)top--;
result[++top]=A[i];
}
int ans=top;//排除共线
for(i=n-2;i>=0;--i){
while(top>ans&&cp(result[top-1],result[top],A[i])<=0)top--;
result[++top]=A[i];
}
printf("%lld\n",rotating_calipers(top));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  POJ2187Beauty Contes