您的位置:首页 > 其它

ZOJ 3872 Beauty of Array

2015-09-06 12:38 274 查看
Edward has an array A with N integers. He defines the beauty of an array as the summation of all distinct integers in the array. Now Edward wants to know the summation of the beauty of all contiguous subarray of the array
A.

Input

There are multiple test cases. The first line of input contains an integer
T indicating the number of test cases. For each test case:

The first line contains an integer N (1 <= N <= 100000), which indicates the size of the array. The next line contains
N positive integers separated by spaces. Every integer is no larger than 1000000.

Output

For each case, print the answer in one line.

Sample Input

3
5
1 2 3 4 5
3
2 3 3
4
2 3 3 2


Sample Output

105
21
38


定义一个序列的美丽值为序列中不同数的和,求一个序列的所有子序列的美丽值的和

#include <stdio.h>
#include <string.h>
int main()
{
long long int dp[100005],pre[100005];
int n,cas,temp;
scanf("%d",&cas);
while(cas--)
{
scanf("%d",&n);
memset(pre,0,sizeof pre);
memset(dp,0,sizeof dp);
for(int i=1;i<=n;i++)
{
scanf("%d",&temp);
dp[i]=dp[i-1]+(i-pre[temp])*temp;//之前的加上 i*temp(每项都多了一个temp)但因为重复了 要减去pre[temp]的temp次
pre[temp]=i;
}
long long int ans=0;
for(int i=1;i<=n;i++)
ans+=dp[i];
printf("%lld\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: