您的位置:首页 > 其它

1028. List Sorting (25)

2015-09-05 23:03 295 查看
原题地址:http://www.patest.cn/contests/pat-a-practise/1028

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student’s record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID’s; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID’s in increasing order.

Sample Input 1

3 1

000007 James 85

000010 Amy 90

000001 Zoe 60

Sample Output 1

000001 Zoe 60

000007 James 85

000010 Amy 90

Sample Input 2

4 2

000007 James 85

000010 Amy 90

000001 Zoe 60

000002 James 98

Sample Output 2

000010 Amy 90

000002 James 98

000007 James 85

000001 Zoe 60

Sample Input 3

4 3

000007 James 85

000010 Amy 90

000001 Zoe 60

000002 James 90

Sample Output 3

000001 Zoe 60

000007 James 85

000002 James 90

000010 Amy 90

解题思路:考察STL中sort用法。但定睛一看我当时竟然是用qsort,还是太菜了

代码如下:

#include <stdio.h>
#include <algorithm>
#include <cstring>
#define MAXN 100010
typedef struct record{
char id[8];
char name[10];
int grade;
}rec;

rec st[MAXN];
int N,C;

int cmp1(const void* _a, const void* _b){
rec a = *(rec*)_a;
rec b = *(rec*)_b;
return strcmp(a.id,b.id);
}

int cmp2(const void* _a, const void* _b){
rec a = *(rec*)_a;
rec b = *(rec*)_b;
int t = strcmp(a.name,b.name);
if(t == 0) return strcmp(a.id,b.id);
else return t;
}

int cmp3(const void* _a, const void* _b){
rec a = *(rec*)_a;
rec b = *(rec*)_b;
int t = a.grade - b.grade;
if(t > 0) return 1;
else if(t < 0) return -1;
else return strcmp(a.id,b.id);
}

int main(){
freopen("1028.txt","r",stdin);
scanf("%d%d",&N,&C);
for(int i = 0; i < N; i++){
scanf("%s%s%d",&st[i].id,&st[i].name,&st[i].grade);
}
switch(C){
case 1: qsort(st,N,sizeof(st[0]),cmp1); break;
case 2: qsort(st,N,sizeof(st[0]),cmp2); break;
case 3: qsort(st,N,sizeof(st[0]),cmp3); break;
}
for(int i = 0; i < N; i++){
printf("%s %s %d\n",st[i].id,st[i].name,st[i].grade);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: