您的位置:首页 > 其它

1004. 成绩排名 (20)

2015-09-05 20:28 459 查看


输入格式:每个测试输入包含1个测试用例,格式为

第1行:正整数n
第2行:第1个学生的姓名 学号 成绩
第3行:第2个学生的姓名 学号 成绩
... ... ...
第n+1行:第n个学生的姓名 学号 成绩

其中姓名和学号均为不超过10个字符的字符串,成绩为0到100之间的一个整数,这里保证在一组测试用例中没有两个学生的成绩是相同的。

输出格式:对每个测试用例输出2行,第1行是成绩最高学生的姓名和学号,第2行是成绩最低学生的姓名和学号,字符串间有1空格。
输入样例:
3
Joe Math990112 89
Mike CS991301 100
Mary EE990830 95

输出样例:
Mike CS991301
Joe Math990112

[code]//用一个struct记录每个学生的信息,比较分数得到分数最低的和最高的学生,然后输出这两个对象
#include <iostream>
#include<string>

using namespace std;

struct student{
string name;
string id;
};
int main(){
int n; cin >> n;
int maxscore = -1, minscore = 101;
student maxstudent, minstudent;
while (n--){
string _name,_id;
int _score;
cin >> _name>>_id>>_score;
if (_score > maxscore){
maxscore = _score;
maxstudent.id = _id;
maxstudent.name = _name;
}
if (_score < minscore){
minscore = _score;
minstudent.id = _id;
minstudent.name = _name;
}
}
cout << maxstudent.name << " " << maxstudent.id << endl;
cout << minstudent.name << " " << minstudent.id << endl;
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: