您的位置:首页 > 其它

HDU 3555 Bomb

2015-09-04 19:22 323 查看

Bomb

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 10967 Accepted Submission(s): 3890


[align=left]Problem Description[/align]
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence "49", the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

[align=left]Input[/align]
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

[align=left]Output[/align]
For each test case, output an integer indicating the final points of the power.

[align=left]Sample Input[/align]

3

1

50

500

[align=left]Sample Output[/align]

0

1

15

Hint

From 1 to 500, the numbers that include the sub-sequence "49" are "49","149","249","349","449","490","491","492","493","494","495","496","497","498","499",
so the answer is 15.

[align=left]Author[/align]
fatboy_cw@WHU

[align=left]Source[/align]
2010 ACM-ICPC Multi-University Training Contest(12)——Host by WHU

解题:数位dp,我就不说什么了

#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
const int maxn = 21;
LL dp[maxn][3];
int b[maxn];
LL dfs(int p,int st,bool flag){
if(!p) return st == 2;
if(flag && dp[p][st] != -1) return dp[p][st];
int u = flag?9:b[p];
LL ret = 0;
for(int i = 0; i <= u; ++i){
if(st == 1 && i == 9 || st == 2) ret += dfs(p-1,2,flag||(i < u));
else if(i == 4) ret += dfs(p-1,1,flag||(i < u));
else ret += dfs(p-1,0,flag||(i < u));
}
if(flag) dp[p][st] = ret;
return ret;
}
LL solve(LL x){
int len = 0;
while(x){
b[++len] = x%10;
x /= 10;
}
return dfs(len,0,false);
}
int main(){
memset(dp,-1,sizeof dp);
int kase;
scanf("%d",&kase);
while(kase--){
LL tmp;
scanf("%I64d",&tmp);
printf("%I64d\n",solve(tmp));
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: