您的位置:首页 > 其它

poj 2406 Power Strings 【kmp(len/(len-p[len])的灵活运用)】

2015-09-04 12:03 399 查看
[align=center]Power Strings[/align]

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 38316Accepted: 15892
Description
Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined
in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.

Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint
This problem has huge input, use scanf instead of cin to avoid time limit exceed.
Source
Waterloo local 2002.07.01

思路:

先求p数组的值,然后判断是否循环,如果整体不是循环的,那么直接输出1,否则输出len/(len-p[len])!

代码:

#include <stdio.h>
#include <string.h>
char a[1000005];
int p[1000005];
int len;
void getp()
{
int i=0,j=-1;
p[0]=-1;
while(i<len)
{
if(j==-1||a[i]==a[j])
{
i++;j++;
p[i]=j;
}
else
j=p[j];
}
}
int main()
{
while(scanf("%s",a)&&a[0]!='.')
{
len=strlen(a);
getp();
if(len%(len-p[len])==0)//先判断是否是循环,如果是,则求循环的次数
printf("%d\n",len/(len-p[len]));
else//否则输出1
printf("1\n");
}//如果你不判断直接输出len/(len-p[len]),则会出错!(例如:abcabcab本应该输出1,但是实际输出2)
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: