您的位置:首页 > 其它

【POJ2771】【最大二分匹配】【反向图最小独立集】

2015-09-04 09:35 387 查看
Guardian of Decency

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 5292Accepted: 2217
Description

Frank N. Stein is a very conservative high-school teacher. He wants to take some of his students on an excursion, but he is afraid that some of them might become couples. While you can never exclude this possibility, he has made some rules that he thinks indicates
a low probability two persons will become a couple:

Their height differs by more than 40 cm.

They are of the same sex.

Their preferred music style is different.

Their favourite sport is the same (they are likely to be fans of different teams and that would result in fighting).

So, for any two persons that he brings on the excursion, they must satisfy at least one of the requirements above. Help him find the maximum number of persons he can take, given their vital information.

Input

The first line of the input consists of an integer T ≤ 100 giving the number of test cases. The first line of each test case consists of an integer N ≤ 500 giving the number of pupils. Next there will be one line for each pupil consisting of four space-separated
data items:

an integer h giving the height in cm;

a character 'F' for female or 'M' for male;

a string describing the preferred music style;

a string with the name of the favourite sport.

No string in the input will contain more than 100 characters, nor will any string contain any whitespace.

Output

For each test case in the input there should be one line with an integer giving the maximum number of eligible pupils.
Sample Input
2
4
35 M classicism programming
0 M baroque skiing
43 M baroque chess
30 F baroque soccer
8
27 M romance programming
194 F baroque programming
67 M baroque ping-pong
51 M classicism programming
80 M classicism Paintball
35 M baroque ping-pong
39 F romance ping-pong
110 M romance Paintball

Sample Output
3
7

Source

Northwestern Europe 2005

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
   
const int N = 550;
int g

;
int used
;
int uN,vN;
int match
;
bool dfs(int u)  
{  
    for(int i=1;i<=vN;i++)  
    {  
        if(!used[i] && g[u][i])  
        {  
            used[i] = true;  
            if(match[i] == -1 || dfs(match[i]))  
            {  
                match[i] = u;  
                return true;  
            }  
        }  
    }  
    return false;  
}  
int hungary()  
{  
    int ret = 0;  
    for(int i=1;i<=uN;i++)     
    {  
        memset(used,0,sizeof(used));  
        if(dfs(i))  ret++;  
    }  
    return ret;
}

int T;
int n;
struct Node
{
	int age;
    char s1[4];
	char s2[110];
	char s3[110];
	void input()
	{
		scanf("%d%s%s%s",&age,s1,s2,s3);
	}	
}node[550];
int main()
{
    scanf("%d",&T);
	while(T --)
	{
		scanf("%d",&n);
		memset(g,0,sizeof(g));
		memset(match,-1,sizeof(match));
		for(int i=1;i<=n;i++)
		{
			node[i].input();
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=1;j<=n;j++)
			{
				if(abs(node[i].age-node[j].age) <= 40 && strcmp(node[i].s1,node[j].s1) !=0 &&
						strcmp(node[i].s2,node[j].s2)==0 && strcmp(node[i].s3,node[j].s3) != 0)
				{
				//	cout << i << " " << j << endl;
					g[i][j] = g[j][i] = 1;
				}
			}
		}
		uN = vN = n ;
		printf("%d\n",n-(hungary()) / 2);
	}
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: