您的位置:首页 > 其它

hdu 4006__The kth great number(STL)

2015-09-04 08:44 519 查看

The kth great number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)

Total Submission(s): 8641 Accepted Submission(s): 3407



Problem Description
Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao
is feeling giddy. Now, try to help Xiao Bao.


Input
There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that
Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.



Output
The output consists of one integer representing the largest number of islands that all lie on one line.



Sample Input
8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q




Sample Output
1
2
3

HintXiao  Ming  won't  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).




Source
The
36th ACM/ICPC Asia Regional Dalian Site —— Online Contest


Recommend
lcy | We have carefully selected several similar problems for you: 4003 4007 4004 4008 4005


题意:先输入n和k,接下来n行,每行输入一个字母c,当c='I'时,写下一个数字,当c=‘Q'时求写下的数中第k大的数。

做法:使用STL中的multiset容器,这种容器与set的最大区别就是不去重性。

代码如下:



#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>
using namespace std;
int main()
{
    multiset<int> s;
    int n,k,a;
    char ss[2];
    while(~scanf("%d%d",&n,&k)) {
        s.clear();
        for(int i=0;i<n;i++) {
            scanf("%s",ss);
            if(ss[0]=='I') {
                scanf("%d",&a);
                s.insert(a);
                if(s.size()>k) {
                    s.erase(s.begin());
                }
            }
            else {
                printf("%d\n",*s.begin());
            }
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: