您的位置:首页 > 其它

HDOJ3018 Ant Trip(欧拉回路 + 并查集)

2015-09-03 22:20 387 查看


Ant Trip

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2055 Accepted Submission(s): 796



Problem Description

Ant Country consist of N towns.There are M roads connecting the towns.

Ant Tony,together with his friends,wants to go through every part of the country.

They intend to visit every road , and every road must be visited for exact one time.However,it may be a mission impossible for only one group of people.So they are trying to divide all the people into several groups,and each may start at different town.Now
tony wants to know what is the least groups of ants that needs to form to achieve their goal.





Input

Input contains multiple cases.Test cases are separated by several blank lines. Each test case starts with two integer N(1<=N<=100000),M(0<=M<=200000),indicating that there are N towns and M roads in Ant Country.Followed by M lines,each line contains two integers
a,b,(1<=a,b<=N) indicating that there is a road connecting town a and town b.No two roads will be the same,and there is no road connecting the same town.



Output

For each test case ,output the least groups that needs to form to achieve their goal.



Sample Input

3 3
1 2
2 3
1 3

4 2
1 2
3 4




Sample Output

1
2

Hint

New ~~~ Notice: if there are no road connecting one town ,tony may forget about the town.
In sample 1,tony and his friends just form one group,they can start at either town 1,2,or 3.
In sample 2,tony and his friends must form two group.




经过每条边一次,每次一笔画,问你最少画多少次,孤立点不算其中。通过并查集判断连通集的数量,点的度数奇偶性判断。

笔画数 = 奇度数 + 欧拉回路数。

AC代码:

#include "iostream"
#include "cstdio"
#include "cstring"
#include "algorithm"
#include "vector"
using namespace std;
const int MAXN = 1e5 + 5;
int n, m, par[MAXN], deg[MAXN], odd[MAXN];
bool vis[MAXN];
vector<int> v;
int find(int x)
{
	if(x == par[x]) return x;
	return par[x] = find(par[x]);
}
int main(int argc, char const *argv[])
{
	while(scanf("%d%d", &n, &m) != EOF) {
		v.clear();
		memset(deg, 0, sizeof(deg));
		memset(odd, 0, sizeof(odd));
		memset(vis, false, sizeof(vis));
		for(int i = 1; i <= n; ++i) 
			par[i] = i;
		for(int i = 0; i < m; ++i) {
			int a, b;
			scanf("%d%d", &a, &b);
			int fa = find(a), fb = find(b);
			deg[a]++, deg[b]++;
			par[fb] = fa;
		}
		for(int i = 1; i <= n; ++i) {
			int x = find(i);
			if(!vis[x]) {
				v.push_back(x);
				vis[x] = true;
			}
			if(deg[i] & 1) odd[x]++;
		}
		int ans = 0;
		for(int i = 0; i < v.size(); ++i) {
			int x = v[i];
			if(deg[x] == 0) continue;
			if(odd[x] == 0) ans++;
			else ans += odd[x] >> 1;
		}
		printf("%d\n", ans);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: