您的位置:首页 > 其它

HDU 4730 We Love MOE Girls

2015-09-03 19:22 417 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4730


We Love MOE Girls

Problem Description

Chikami Nanako is a girl living in many different parallel worlds. In this problem we talk about one of them.

In this world, Nanako has a special habit. When talking with others, she always ends each sentence with "nanodesu".

There are two situations:

If a sentence ends with "desu", she changes "desu" into "nanodesu", e.g. for "iloveyoudesu", she will say "iloveyounanodesu". Otherwise, she just add "nanodesu" to the end of the original sentence.

Given an original sentence, what will it sound like aften spoken by Nanako?



Input

The first line has a number T (T <= 1000) , indicating the number of test cases.

For each test case, the only line contains a string s, which is the original sentence.

The length of sentence s will not exceed 100, and the sentence contains lowercase letters from a to z only.



Output

For every case, you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output which Nanako will say.



Sample Input

2
ohayougozaimasu
daijyoubudesu




Sample Output

Case #1: ohayougozaimasunanodesu
Case #2: daijyoubunanodesu




题意:


超水题,如果末尾是desu结尾就改成nanodesu

否则直接加nanodesu,嘿嘿,这其实是日语的语气词啊,这题目真可爱!!!






#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
char a[105];
int main()
{
     int t,k=1;
     scanf("%d",&t);
     while(t--)
     {
         scanf("%s",a);
         int len=strlen(a);
         printf("Case #%d: ",k++);
         if(a[len-4]=='d' && a[len-3]=='e' && a[len-2]=='s' && a[len-1]=='u')
         {
             for(int i=0;i<len-4;i++)
                printf("%c",a[i]);
             printf("nanodesu\n");
             continue;
         }
         printf("%snanodesu\n",a);
     }
     return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: