您的位置:首页 > 其它

POJ 1002 487-3279

2015-09-02 23:09 531 查看
487-3279

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 261116Accepted: 46520
Description
Businesses like to have memorable telephone numbers. One way to make a telephone number memorable is to have it spell a memorable word or phrase. For example, you can call the University of Waterloo by dialing the memorable TUT-GLOP.
Sometimes only part of the number is used to spell a word. When you get back to your hotel tonight you can order a pizza from Gino's by dialing 310-GINO. Another way to make a telephone number memorable is to group the digits in a memorable way. You could
order your pizza from Pizza Hut by calling their ``three tens'' number 3-10-10-10.

The standard form of a telephone number is seven decimal digits with a hyphen between the third and fourth digits (e.g. 888-1200). The keypad of a phone supplies the mapping of letters to numbers, as follows:

A, B, and C map to 2

D, E, and F map to 3

G, H, and I map to 4

J, K, and L map to 5

M, N, and O map to 6

P, R, and S map to 7

T, U, and V map to 8

W, X, and Y map to 9

There is no mapping for Q or Z. Hyphens are not dialed, and can be added and removed as necessary. The standard form of TUT-GLOP is 888-4567, the standard form of 310-GINO is 310-4466, and the standard form of 3-10-10-10 is 310-1010.

Two telephone numbers are equivalent if they have the same standard form. (They dial the same number.)

Your company is compiling a directory of telephone numbers from local businesses. As part of the quality control process you want to check that no two (or more) businesses in the directory have the same telephone number.

Input
The input will consist of one case. The first line of the input specifies the number of telephone numbers in the directory (up to 100,000) as a positive integer alone on the line. The remaining lines list the telephone numbers
in the directory, with each number alone on a line. Each telephone number consists of a string composed of decimal digits, uppercase letters (excluding Q and Z) and hyphens. Exactly seven of the characters in the string will be digits or letters.

Output
Generate a line of output for each telephone number that appears more than once in any form. The line should give the telephone number in standard form, followed by a space, followed by the number of times the telephone number
appears in the directory. Arrange the output lines by telephone number in ascending lexicographical order. If there are no duplicates in the input print the line:

No duplicates.

Sample Input
12
4873279
ITS-EASY
888-4567
3-10-10-10
888-GLOP
TUT-GLOP
967-11-11
310-GINO
F101010
888-1200
-4-8-7-3-2-7-9-
487-3279

Sample Output
310-1010 2
487-3279 4
888-4567 3

Source
East Central North America 1999

这道模拟题还是值得做的。

题目大该意思是说:输入的时候有不同的输入字符方式,通过映射和筛选后,最终都能表示为7位的电话号码。统计这些电话号码,按字典序指定格式输出次数大于1的电话号码以及对应的次数。

我的方法是,先把电话号码转成数字,然后排序,这样就得到了输出时的顺序,然后对于出现次数大于1次的数字,按要求输出即可。

#include <stdio.h>
#include <ctype.h>
#include <string.h>
#include <algorithm>
#define N  10000000
using namespace std;
int cnt
;
char s[100];
int ans[100005];
bool vis
;
int alpha2digit(char ch)
{
if(ch=='A' || ch=='B' || ch=='C')
return 2;
if(ch=='D' || ch=='E' || ch=='F')
return 3;
if(ch=='G' || ch=='H' || ch=='I')
return 4;
if(ch=='J' || ch=='K' || ch=='L')
return 5;
if(ch=='M' || ch=='N' || ch=='O')
return 6;
if(ch=='P' || ch=='R' || ch=='S')
return 7;
if(ch=='T' || ch=='U' || ch=='V')
return 8;
if(ch=='W' || ch=='X' || ch=='Y')
return 9;
}
void printnum(int num)
{
int dig[7];
memset(dig,0,sizeof(dig));
int c=6;
do
{
dig[c--]=num%10;
}while(num/=10);
for(int i=0;i<3;i++)
printf("%d",dig[i]);
printf("-");
for(int i=3;i<7;i++)
printf("%d",dig[i]);
}
int main()
{
int t,i=0;
scanf("%d",&t);
memset(cnt,0,sizeof(cnt));
memset(vis,0,sizeof(vis));
while(t--)
{
int temp=0;
scanf("%s",s);
int len=strlen(s);
for(int i=0;i<len;i++)
if(s[i]=='-' || s[i]=='Q' || s[i]=='Z')
continue;
else if(isdigit(s[i]))
{
temp=10*temp+(s[i]-'0');
}
else if(isalpha(s[i]))
{
temp=10*temp+alpha2digit(s[i]);
}
else
continue;
cnt[temp]++;
ans[i++]=temp;
}
sort(ans,ans+i);
int sum=0;
for(int j=0;j<i;j++)
if(cnt[ans[j]]>1&&!vis[ans[j]])
{
printnum(ans[j]);
printf(" %d\n",cnt[ans[j]]);
vis[ans[j]]=1;
}
else
sum++;
if(sum==i)
printf("No duplicates. \n");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: