您的位置:首页 > 其它

1180 -- 三点顺序

2015-09-02 15:00 351 查看
三点顺序
Time Limit:1000MS Memory Limit:65536K

Total Submit:24 Accepted:22
Description
现在给你不共线的三个点A,B,C的坐标,它们一定能组成一个三角形,现在让你判断A,B,C是顺时针给出的还是逆时针给出的?

Input
每行是一组测试数据,有6个整数x1,y1,x2,y2,x3,y3分别表示A,B,C三个点的横纵坐标。(坐标值都在0到10000之间)

输入0 0 0 0 0 0表示输入结束

测试数据不超过10000组

Output
如果这三个点是顺时针给出的,请输出1,逆时针给出则输出0

Sample Input
0 0 1 1 1 3
0 1 1 0 0 0
0 0 0 0 0 0
样例输出

Sample Output
0
1

Source
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;

namespace AK1180 {
class Program {
static void Main(string[] args) {
string sb;
while ((sb = Console.ReadLine()) != null) {
string[] s = sb.Split();
int[] a = new int[6];
for (int i = 0; i < 6; i++) a[i] = int.Parse(s[i]);
if (a[0] + a[1] + a[2] + a[3] + a[4] + a[5] == 0) break;
//2-0 * 5-1 - 3-1 * 4-0
if ((a[2] - a[0]) * (a[5] - a[1]) - (a[3] - a[1]) * (a[4] - a[0]) > 0)
Console.WriteLine("0");
else
Console.WriteLine("1");
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: