您的位置:首页 > Web前端

poj3253Fence Repair(贪心)

2015-09-02 10:58 316 查看
Fence Repair

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 32802Accepted: 10581
Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤
50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made;
you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will
result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks

Lines 2..N+1: Each line contains a single integer describing the length of a needed plank
Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts
Sample Input
3
8
5
8

Sample Output
34

Hint
<span style="font-size:14px;">//poj3253-Fence Repair(贪心+优先队列)
//本题的解题思路是用贪心,可以利用优先队列的特点来使解题更简便;
//首先,为了求最小的开销且将木块按要求切好;不妨逆着思考,假如木块按要求切好,求将其还原为原来的一个木块的
//最小开销;这样每次选当前最短的两个木块合并,这样当前的开销总是最小,最后,总开销也就最小; 
#include<cstdio>
#include<queue>
#include<algorithm>
using namespace std;
int main()
{
	int n,i,j;
	long long int cnt;
	int a[21000];
	priority_queue<int,vector<int>, greater<int> >q;//声明一个从小到大的优先队列;
	while(scanf("%d",&n)!=EOF)
	{
		cnt=0;
		for(i=0;i<n;i++)
		{
		  scanf("%d",&a[i]);
		  q.push(a[i]);
	    }
		while(q.size()>1)
		{
			int x=q.top();
			q.pop();
			int y=q.top();
			q.pop();
			cnt+=x+y;
			q.push(x+y);
		}
	printf("%lld\n",cnt);	
	}
return 0;
}</span><span style="font-size: 18pt;">
 </span>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: