您的位置:首页 > 其它

hdu4465 Candy(快速排列组合+概率)

2015-09-02 10:05 351 查看
链接:http://acm.hdu.edu.cn/showproblem.php?pid=4465

Candy

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2524 Accepted Submission(s): 1103

Special Judge


Problem Description
LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first
box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.

He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?


Input
There are several test cases.

For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 105) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).

Input is terminated by EOF.


Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.

Any answer with an absolute error less than or equal to 10-4 would be accepted.


Sample Input
10 0.400000
100 0.500000
124 0.432650
325 0.325100
532 0.487520
2276 0.720000




Sample Output
Case 1: 3.528175
Case 2: 10.326044
Case 3: 28.861945
Case 4: 167.965476
Case 5: 32.601816
Case 6: 1390.500000




Source
2012 Asia Chengdu Regional Contest

题意:有两个盒子各有n个糖,每天随机选一个(概率分别为p,1-p),然后吃一颗糖。直到有一天,打开一个盒子看没糖l!输入n,p,求此时另一个盒子里糖的个数数学期望。

分析:根据期望的定义,不妨设最后打开第一个盒子,此时第二个盒子有i颗,则这之前打开过n+(n-i)次盒子,其中有n次取的是盒子1,其余n-i次取的盒子2,概率为C(2n-i,n)P^(n+1)*(1-P)^(n-i)。注意P的指数是n+1,因为除了前面打开过n次盒子1之外,最后又打开了一次。

当然光计算出这个概率,这题还是很难实现的,我们需要优化一下。我们可以利用对数,设v1(i)=ln(C(2n-i,n))+(n+1)ln(P)+(n-i)ln(1-P),则“最后打开第一个盒子”对应的数学期望为 i*e^v1(i)。

同理,当最后打开的是第二个盒子,对数为 v2(i)=ln(C(2n-i,n))+(n+1)ln(1-p)+(n-i)ln(p),对应的数学期望为 i*e^v2(i)。

根据数学期望的定义,最终答案为 sum{i*(e^v1(i)+e^v2(i))。 (参考算法竞赛入门经典333页)

#include<iostream>
 #include<cstdio>
 #include<cmath>
 #include<cstring>
 using namespace std;
 const int maxn=400040;
 double nlog[maxn],p,q; //nlog
记录log[1]+log[2]+...+log

 int n;
 double cal(int n,int m)
 {
     return nlog
-nlog[m]-nlog[n-m];
 }
 int main()
 {
     int cas=0;
     memset(nlog,0,sizeof(nlog));
     for(int i=1;i<maxn;i++) // 对nlog
做预处理
        nlog[i] +=nlog[i-1] + log(i);
     while(scanf("%d %lf",&n,&p) != EOF)
     {
         q=log(1-p); // 直接对(1-p)取对数,后面运用到
         p=log(p);
         double ans=0;
         for(int i=0;i<=n;i++)
         {
             ans+=i*(exp(cal(2*n-i,n)+(n+1)*p+(n-i)*q) + exp(cal(2*n-i,n)+(n+1)*q+(n-i)*p));
         }
         printf("Case %d: %lf\n",++cas,ans);
     }
     return 0;
 }
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: