您的位置:首页 > 产品设计 > UI/UE

HDU 1711 Number Sequence kmp

2015-08-31 19:47 591 查看

Number Sequence

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15821 Accepted Submission(s): 6978



Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M].
If there are more than one K exist, output the smallest one.



Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate
a[1], a[2], ...... , a
. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].



Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.



Sample Input
2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1




Sample Output
6
-1




Source
HDU 2007-Spring Programming Contest



Recommend
lcy | We have carefully selected several similar problems for you: 1358 3336 1686 3746 1251

ACcode

#include <map>
#include <queue>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#define maxn 100
using namespace std;
int N[1000000+10];
int M[10000+10];
int nex[10000+10];
int main(){
    int loop,la,lb;
    scanf("%d",&loop);
    while(loop--){
        scanf("%d%d",&la,&lb);
        for(int i=0;i<la;++i)
            scanf("%d",&N[i]);
        for(int i=0;i<lb;++i)
            scanf("%d",&M[i]);
        int pos=0,j=0;
        nex[0]=-1;
        nex[1]=0;
        for(int i=2;i<lb;++i){
            while(pos>=0&&M[pos]!=M[i-1])
                pos=nex[pos];
            nex[i]=++pos;
        }
        int p=0,cur=0,t=-1;
        while(cur<la){
            if(N[cur]==M[p]){
                cur++;
                p++;
            }
            else if(p>=0)
                p=nex[p];
            else {
                cur++;
                p=0;
            }
            if(p==lb){
                t=cur-lb+1;
                break;
            }
        }
        printf("%d\n",t);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: