您的位置:首页 > 其它

HDU——1253 胜利大逃亡

2015-08-31 12:41 387 查看


胜利大逃亡

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 29562 Accepted Submission(s): 11148



Problem Description

Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.



Input

输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.

Output

对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.

Sample Input

1
3 3 4 20
0 1 1 1
0 0 1 1
0 1 1 1
1 1 1 1
1 0 0 1
0 1 1 1
0 0 0 0
0 1 1 0
0 1 1 0


Sample Output

11
广搜,与/article/11084373.html思想相同
代码如下:
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<stdlib.h>
#include<ctype.h>
#include<iostream>
#include<string>
#include<algorithm>
#include<set>
#include<vector>
#include<queue>
#include<map>
#include<numeric>
#include<stack>
#include<list>
const int INF=1<<30;
const int inf=-(1<<30);
const int MAX=100010;

using namespace std;

struct data
{
int x,y,z;
int step;
} st,pre;
int s[6][3]= {{0,-1,0},{0,1,0},{0,0,-1},{0,0,1},{1,0,0},{-1,0,0}};
int T,t,A,B,C;
int a[100][100][100],b[100][100][100];
int sx,sy,sz,ex,ey,ez;
int bfs()
{
memset(b,0,sizeof(b));
queue<data>que;
st.x=sx;
st.y=sy;
st.z=sz;
st.step=0;
que.push(st);
b[sx][sy][sz]=1;
while(!que.empty())
{
st=que.front();
que.pop();
if(st.x==ex&&st.y==ey&&st.z==ez&&st.step<=t)
return st.step;
for(int i=0; i<6; i++)
{
int x=st.x+s[i][0];
int y=st.y+s[i][1];
int z=st.z+s[i][2];
if(x>=0&&x<A&&y>=0&&y<B&&z>=0&&z<C&&!b[x][y][z]&&!a[x][y][z])
{
b[x][y][z]=1;
pre.x=x;
pre.y=y;
pre.z=z;
pre.step=st.step+1;
que.push(pre);
}
}
}
return -1;
}

int main()
{
scanf("%d",&T);
while(T--)
{
scanf("%d%d%d%d",&A,&B,&C,&t);
sx=sy=sz=0;
ex=A-1;
ey=B-1;
ez=C-1;
for(int i=0; i<A; i++)
for(int j=0; j<B; j++)
for(int k=0; k<C; k++)
scanf("%d",&a[i][j][k]);
printf("%d\n",bfs());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: