您的位置:首页 > 其它

HDU 1258 Sum It Up 深搜

2015-08-31 10:50 405 查看


Crawling in process...
Crawling failed Time Limit:1000MS
Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status
Practice
HDU 1258

Description

Given a specified total t and a list of n integers, find all distinct sums using numbers from the list that add up to t. For example, if t=4, n=6, and the list is [4,3,2,2,1,1], then there are four different sums that equal 4: 4,3+1,2+2,
and 2+1+1.(A number can be used within a sum as many times as it appears in the list, and a single number counts as a sum.) Your job is to solve this problem in general.

Input

The input will contain one or more test cases, one per line. Each test case contains t, the total, followed by n, the number of integers in the list, followed by n integers x1,...,xn. If n=0 it signals the end of the input; otherwise,
t will be a positive integer less than 1000, n will be an integer between 1 and 12(inclusive), and x1,...,xn will be positive integers less than 100. All numbers will be separated by exactly one space. The numbers in each list appear in nonincreasing order,
and there may be repetitions.

Output

For each test case, first output a line containing 'Sums of', the total, and a colon. Then output each sum, one per line; if there are no sums, output the line 'NONE'. The numbers within each sum must appear in nonincreasing order.
A number may be repeated in the sum as many times as it was repeated in the original list. The sums themselves must be sorted in decreasing order based on the numbers appearing in the sum. In other words, the sums must be sorted by their first number; sums
with the same first number must be sorted by their second number; sums with the same first two numbers must be sorted by their third number; and so on. Within each test case, all sums must be distince; the same sum connot appear twice.

Sample Input

4 6 4 3 2 2 1 1
5 3 2 1 1
400 12 50 50 50 50 50 50 25 25 25 25 25 25
0 0


Sample Output

Sums of 4:
4
3+1
2+2
2+1+1
Sums of 5:
NONE
Sums of 400:
50+50+50+50+50+50+25+25+25+25
50+50+50+50+50+25+25+25+25+25+25


题意:就是给定一个数(总和),然后给定n个数,让你求满足总和的所有不同的组合并输出这些组合
思路:深搜,从第0个开始深搜,当第0个的所有组合满足后,进行下一个与当前不同数的搜索,
AC代码:
#include <iostream>

#include <cstdio>

#include<cstring>

#include<algorithm>

using namespace std;

int t;

int n;

int sum;

int tag,k;

int a[13];//给定的数

int b[13];//记录满足条件的数

void dfs(int x){

int i;

if(sum>t){

return ;

}

if(sum==t){//输出

for(int j=0;j<k-1;j++){

printf("%d+",b[j]);

}

printf("%d\n",b[k-1]);

tag=1;

return;

}

for(i=x;i<n;i++){

sum+=a[i];

b[k++]=a[i];

dfs(i+1);//搜索下一个

sum-=a[i];

while(i+1<n&&a[i]==a[i+1]){ i++;}//回溯回去的时候避免搜索相同的数

k--;

}

}

int main(){

while(~scanf("%d",&t)){

scanf("%d",&n);

if(n==0){break;}

for(int i=0;i<n;i++){

scanf("%d",&a[i]);

}

sum=0;

tag=0;

k=0;

printf("Sums of %d:\n",t);

dfs(0);

if(tag==0){

printf("NONE\n");

}

}

return 0;

}
注意;哪里必须避开搜素相同的数,深搜的想法主要感觉是回溯,回溯回去后倒地怎么来操作;
这种题看着简单,做起来也不容易,,,,菜,,,继续努力。。。。。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: