您的位置:首页 > 其它

poj 2503 Babelfish(字典树·翻译)

2015-08-30 20:44 239 查看
题目:http://poj.org/problem?id=2503

Language:
Default

Babelfish

Time Limit: 3000MSMemory Limit: 65536K
Total Submissions: 37107Accepted: 15811
Description

You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.
Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears
more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.
Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as "eh".
Sample Input
dog ogday
cat atcay
pig igpay
froot ootfray
loops oopslay

atcay
ittenkay
oopslay

Sample Output
cat
eh
loops

Hint

Huge input and output,scanf and printf are recommended.
分析:这和hdu 1075 what are you talking about 很像,甚至比它还要简单。就是利用字典树进行单词翻译。

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
struct node{
    bool cover;
    char word[15];
    node *next[26];
    node(){
        cover=0;
        memset(word,0,sizeof(word));
        memset(next,0,sizeof(next));
    }
};
node *root;
void insert(char *s1,char *s2){
    node *p=root;
    int length=strlen(s2);
    for(int i=0;i<length;i++){
        if(p->next[s2[i]-'a']==0) p->next[s2[i]-'a']=new node();
        p=p->next[s2[i]-'a'];
    }
    p->cover=1;
    strcpy(p->word,s1);
}
void del(node *p){
    if(p==NULL){  return ;  }
    for(int i=0;i<26;i++) del(p->next[i]);
    delete p;
}
char* query(char *s){
    int length=strlen(s);
    node *p=root;
    for(int i=0;i<length;i++){
        if(p->next[s[i]-'a']==0) return 0;
        p=p->next[s[i]-'a'];
    }
    if(p->cover) return p->word;
    return 0;
}
char str[30],s1[15],s2[15];
void strcpy(char *s,char *f,int start,int end){
    for(int i=start;i<=end;i++){
        s[i-start]=f[i];
    }
    s[end-start+1]=0;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    root=new node();
    while(gets(str)){
        int length1,slen=strlen(str);  //slen=0意味着空行
        if(slen==0) break;
        for(int i=0;i<slen;i++){
            if(str[i]==' '){
                length1=i;
                break;
            }
        }
        strcpy(s1,str,0,length1-1);
        strcpy(s2,str,length1+1,slen-1);
        //cout<<s1<<" "<<s2<<endl;
        insert(s1,s2);
    }
    while(~scanf("%s",s1)){
        char *ans=query(s1);  //返回字符串
        if(ans) printf("%s\n",ans);
        else printf("eh\n");
    }
    del(root);
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: