您的位置:首页 > 其它

2012 #3 Flowers

2015-08-30 19:36 155 查看
Flowers
Time Limit:2000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status Practice HDU 4325

Description

As is known to all, the blooming time and duration varies between different kinds of flowers. Now there is a garden planted full of flowers. The gardener wants to know how many flowers will bloom in the garden in a specific time. But there are too many flowers in the garden, so he wants you to help him.

Input

The first line contains a single integer t (1 <= t <= 10), the number of test cases.
For each case, the first line contains two integer N and M, where N (1 <= N <= 10^5) is the number of flowers, and M (1 <= M <= 10^5) is the query times.
In the next N lines, each line contains two integer S i and T i (1 <= S i <= T i <= 10^9), means i-th flower will be blooming at time [S i, T i].
In the next M lines, each line contains an integer T i, means the time of i-th query.

Output

For each case, output the case number as shown and then print M lines. Each line contains an integer, meaning the number of blooming flowers.
Sample outputs are available for more details.

Sample Input

2
1 1
5 10
4
2 3
1 4
4 8
1
4
6

Sample Output

Case #1:
0
Case #2:
1
2
1

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
int T;
int i,j;
int n,m,ca=1;
int l[100005],r[100005];
scanf("%d",&T);
while(T--)
{
scanf("%d %d",&n,&m);
for(i=1;i<=n;i++)
scanf("%d %d",&l[i],&r[i]);
sort(l+1,l+n+1);
sort(r+1,r+n+1);
printf("Case #%d:\n",ca);ca++;
for(i=1;i<=m;i++)
{
int x,y,z;
scanf("%d",&z);
x=upper_bound(l+1,l+n+1,z)-(l+1);
y=upper_bound(r+1,r+n+1,z-1)-(r+1);
printf("%d\n",x-y);
}
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: