您的位置:首页 > 其它

poj 1703 Find them, Catch them(并查集)

2015-08-30 13:19 405 查看
Description

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.)

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds:

1. D [a] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs.

2. A [a] [b]
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang.


[b]Input


The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.


Output

For each message "A [a] " in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."


[b]Sample Input


1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4


Sample Output

Not sure yet.
In different gangs.
In the same gang.


Source

POJ Monthly--2004.07.18

并查集,用一个opp数组记录相反的对手,然后进行并查集的合并
刚开始 init()函数忘记加上去了,自己老是这么粗心。。。 还有在判断A的时候,先考虑相同的和不同的,最后就剩下不确定的了。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
#define N 100006
int n,m;
int opp
,fa
;
void init(){
for(int i=0;i<N;i++){
opp[i]=0;
fa[i]=i;
}
}
int find(int x){
return fa[x]==x?x:fa[x]=find(fa[x]);
}
void merge(int x,int y){
int root1=find(x);
int root2=find(y);
if(root1==root2) return;
fa[root1]=root2;
}
int main()
{
int t;
scanf("%d",&t);
while(t--){
init();
scanf("%d%d",&n,&m);
char s[3];
int x,y;
for(int i=0;i<m;i++){
scanf("%s",s);
if(s[0]=='A'){
scanf("%d%d",&x,&y);
if(find(x)==find(y)){
printf("In the same gang.\n");
}else if(find(x)==find(opp[y])){
printf("In different gangs.\n");
}else{
printf("Not sure yet.\n");
}
}
else{
scanf("%d%d",&x,&y);
if(opp[x]==0 && opp[y]==0){
opp[x]=y;
opp[y]=x;
}
else if(opp[x]==0){
opp[x]=y;
merge(x,opp[y]);
}
else if(opp[y]==0){
opp[y]=x;
merge(y,opp[x]);
}
else{
merge(x,opp[y]);
merge(y,opp[x]);
}
}
}
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: