您的位置:首页 > 编程语言 > Java开发

杭电ACM2052java做法

2015-08-30 10:03 459 查看
Picture

Problem Description

Give you the width and height of the rectangle,darw it.

Input

Input contains a number of test cases.For each case ,there are two numbers n and m (0 < n,m < 75)indicate the width and height of the rectangle.Iuput ends of EOF.

Output

For each case,you should draw a rectangle with the width and height giving in the input.

after each case, you should a blank line. 

Sample Input

3 2

Sample Output

+---+

|   |

|   |
+---+

感觉这道题比较水吧,我没想啥好办法,就直接打了

import java.util.Scanner;

public class Main {
public static void main(String[] args){
Scanner scanner=new Scanner(System.in);
while(scanner.hasNextInt()){
int a=scanner.nextInt();
int b=scanner.nextInt();
for(int i=0;i<b+2;i++){
if(i==0||i==b+1){
System.out.print("+");
for(int j=1;j<a+1;j++){
System.out.print("-");
}
System.out.println("+");
}
else{
System.out.print("|");
for(int j=1;j<a+1;j++){
System.out.print(" ");
}
System.out.println("|");
}
}
System.out.println();
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: